ipq40xx: use zImage for GL.iNet GL-B1300, GL-S1300 to shrink below 4096k
authorSzabolcs Hubai <szab.hu@gmail.com>
Sat, 9 Oct 2021 23:32:30 +0000 (01:32 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 10 Oct 2021 14:47:41 +0000 (16:47 +0200)
In the "ipq40xx: switch to Kernel 5.10" discussion at GitHub,
Adrian noted [0] that these GL.iNet Conexa series devices,
GL-B1300 and GL-S1300 failed their image generation [1] as their gzipped
uImage kernel went above 4096k.

While notifying the vendor about this problem [2], I tested all U-Boot
releases from GL.iNet:
- they really fail to boot kernel above 4096k
- they don't support lzma: "Unimplemented compression type 3"
- but they boot zImage

Using zImage (xz compression) the kernel is 2909k which is
more than a megabyte away from the KERNEL_SIZE := 4096k limit.

The gzip compressed version would be 4116k.

[0]: https://github.com/openwrt/openwrt/pull/4620#issuecomment-932765776
[1]: commit 7b1fa276f5a2 ("ipq40xx: add testing support for kernel 5.10")
[2]: https://forum.gl-inet.com/t/ipq40xx-kernel-size-and-u-boot-v5-10-is-too-big-for-4-mb/17619

Signed-off-by: Szabolcs Hubai <szab.hu@gmail.com>
target/linux/ipq40xx/image/generic.mk

index 18f5d238c75d8568ab20a1fd4c13f8083404a871..e0cfa075415747bf8c95c6186ba1978e4e3a48fd 100644 (file)
@@ -495,7 +495,7 @@ endef
 TARGET_DEVICES += glinet_gl-ap1300
 
 define Device/glinet_gl-b1300
-       $(call Device/FitImage)
+       $(call Device/FitzImage)
        DEVICE_VENDOR := GL.iNet
        DEVICE_MODEL := GL-B1300
        BOARD_NAME := gl-b1300
@@ -507,7 +507,7 @@ endef
 TARGET_DEVICES += glinet_gl-b1300
 
 define Device/glinet_gl-s1300
-       $(call Device/FitImage)
+       $(call Device/FitzImage)
        DEVICE_VENDOR := GL.iNet
        DEVICE_MODEL := GL-S1300
        SOC := qcom-ipq4029