prereq-build: limit argp/fts/obstack/libintl.h to Linux OS
authorChristian Marangi <ansuelsmth@gmail.com>
Mon, 9 Jan 2023 21:16:26 +0000 (22:16 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 10 Jan 2023 12:07:14 +0000 (13:07 +0100)
BSD based OS have different fixup and doesn't require these header.
Limit these Header to Linux based OS.

Fixes: 36bc306ae611 ("prereq-build: add extra check for elfutils required header")
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/prereq-build.mk

index 7b345ebbaa41a70b7d260866a9a09f0192700013..8fae92ab977087f38f9bac051d57e49c8bc1163b 100644 (file)
@@ -204,17 +204,19 @@ $(eval $(call SetupHostCommand,which,Please install 'which', \
        /bin/which which, \
        which which))
 
-$(eval $(call RequireCHeader,argp.h, \
+ifeq ($(HOST_OS),Linux)
+  $(eval $(call RequireCHeader,argp.h, \
        Missing argp.h Please install the argp-standalone package if musl libc))
 
-$(eval $(call RequireCHeader,fts.h, \
+  $(eval $(call RequireCHeader,fts.h, \
        Missing fts.h Please install the musl-fts-dev package if musl libc))
 
-$(eval $(call RequireCHeader,obstack.h, \
+  $(eval $(call RequireCHeader,obstack.h, \
        Missing obstack.h Please install the musl-obstack-dev package if musl libc))
 
-$(eval $(call RequireCHeader,libintl.h, \
+  $(eval $(call RequireCHeader,libintl.h, \
        Missing libintl.h Please install the musl-libintl package if musl libc))
+endif
 
 $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
        mkdir -p $(dir $@)