build, imagebuilder: Do not require compilers
authorSven Roederer <devel-sven@geroedel.de>
Sun, 27 Sep 2020 21:07:38 +0000 (23:07 +0200)
committerPaul Spooren <mail@aparcar.org>
Thu, 31 Dec 2020 19:32:33 +0000 (09:32 -1000)
The buildroot and SDK both require the compilers (gcc, g++) to be
installed on the host system, however the ImageBuilder uses precompiled
binaries.

This patch changes the prerequirements checks to skip the checking for
the compilers if running as ImageBuilder. A similar change has been
made for libncurses-dev in 4a1a58a3e2d2.

Signed-off-by: Sven Roederer <devel-sven@geroedel.de>
Acked-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit ae12a747cae3df16d84b7dc92f39427948d4e8e2)

include/prereq-build.mk

index 622db96ee3abe9cac0c4652859eacbdb4182d0f1..7504d43a7480033c5a1a30fc35dfc9953250d8d1 100644 (file)
@@ -26,6 +26,7 @@ $(eval $(call TestHostCommand,proper-umask, \
        Please build with umask 022 - other values produce broken packages, \
        umask | grep -xE 0?0[012][012]))
 
+ifndef IB
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc) 4.8 or later, \
        $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
@@ -37,7 +38,9 @@ $(eval $(call TestHostCommand,working-gcc, \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -))
+endif
 
+ifndef IB
 $(eval $(call SetupHostCommand,g++, \
        Please install the GNU C++ Compiler (g++) 4.8 or later, \
        $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
@@ -50,6 +53,7 @@ $(eval $(call TestHostCommand,working-g++, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
+endif
 
 ifndef IB
 $(eval $(call TestHostCommand,ncurses, \