at91: sam9x,sama5: fix racy SD card image generation
authorPetr Štetiar <ynezz@true.cz>
Tue, 3 Jan 2023 11:44:51 +0000 (12:44 +0100)
committerPetr Štetiar <ynezz@true.cz>
Wed, 8 Feb 2023 08:16:43 +0000 (09:16 +0100)
We've few low spec (make -j3) build workers attached to the 22.03
buildbot instance which from time to time exhibit following build
failure during image generation (shortened for brewity):

 + dd bs=512 if=root.ext4 of=openwrt-22.03...sdcard.img.gz.img
 dd: failed to open 'root.ext4': No such file or directory

Thats happening likely due to the fact, that on buildbots we've
`TARGET_PER_DEVICE_ROOTFS=y` which produces differently named filesystem
image in the SD card image target dependency chain:

 make_ext4fs -L rootfs ... root.ext4+pkg=68b329da

and that hardcoded `root.ext4` image filename becomes available from
other Make targets in the later stages. So lets fix this issue by using
IMAGE_ROOTFS Make variable which should contain proper path to the root
filesystem image.

Fixing remaining subtargets ommited in commit 5c3679e39b61 ("at91:
sama7: fix racy SD card image generation").

Fixes: 5c3679e39b61 ("at91: sama7: fix racy SD card image generation")
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit 3b669bc3f32f7594f38187a284a65ca2c35a0121)

target/linux/at91/image/sam9x.mk
target/linux/at91/image/sama5.mk

index b6c5e33ac44fe55d84e9b3d995f2431554d1d200..3f57f4c8c86bee2d39eaa82886f025e0e4c37332 100644 (file)
@@ -35,7 +35,7 @@ define Build/at91-sdcard
   ./gen_at91_sdcard_img.sh \
        $@.img \
        $@.boot \
-       $(KDIR)/root.ext4 \
+       $(IMAGE_ROOTFS) \
        $(AT91_SD_BOOT_PARTSIZE) \
        $(CONFIG_TARGET_ROOTFS_PARTSIZE)
 
index 39db3e1cd022b3d140d659d772cc36b699cf434e..7f4dd3316a888e6fc73d5eb42256ca81661169ee 100644 (file)
@@ -39,7 +39,7 @@ define Build/at91-sdcard
   ./gen_at91_sdcard_img.sh \
        $@.img \
        $@.boot \
-       $(KDIR)/root.ext4 \
+       $(IMAGE_ROOTFS) \
        $(AT91_SD_BOOT_PARTSIZE) \
        $(CONFIG_TARGET_ROOTFS_PARTSIZE)