ipq40xx: Netgear LBR20 fix for proper img builds
authorMarcin Gajda <mgajda@o2.pl>
Sat, 24 Feb 2024 16:49:49 +0000 (17:49 +0100)
committerRobert Marko <robimarko@gmail.com>
Sat, 24 Feb 2024 18:49:39 +0000 (19:49 +0100)
Without UBINIZE_OPTS it is possile to have error:
"ubi0 error: ubi_attach_mtd_dev: failed to atach mtd23, error -22"

This solve this problem.

Signed-off-by: Marcin Gajda <mgajda@o2.pl>
target/linux/ipq40xx/image/generic.mk

index 61bc0ad619048590b959da2554854d230e12cd93..8a83e27f543c64a1973008793596a5207621d907 100644 (file)
@@ -849,6 +849,7 @@ define Device/netgear_lbr20
        KERNEL_SIZE := 7340032
        BLOCKSIZE := 128k
        PAGESIZE := 2048
+       UBINIZE_OPTS := -E 5
        IMAGE/factory.img := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
                append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | \
                append-ubi | netgear-dni