build: set up host command for egrep
authorFelix Fietkau <nbd@nbd.name>
Thu, 6 Aug 2020 10:53:14 +0000 (12:53 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 6 Aug 2020 11:17:13 +0000 (13:17 +0200)
It is used for the kernel build and uses GNU specific features

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/prereq-build.mk

index 83dad0f2dc6e6bad1327f62f398d074d2a2eb0bf..4637c6ca50bd6119e4adf269b57a87d70d522809 100644 (file)
@@ -114,6 +114,10 @@ $(eval $(call SetupHostCommand,grep,Please install GNU 'grep', \
        ggrep --version 2>&1 | grep GNU, \
        grep --version 2>&1 | grep GNU))
 
+$(eval $(call SetupHostCommand,egrep,Please install GNU 'grep', \
+       gegrep --version 2>&1 | grep GNU, \
+       egrep --version 2>&1 | grep GNU))
+
 $(eval $(call SetupHostCommand,getopt, \
        Please install an extended getopt version that supports --long, \
        gnugetopt -o t --long test -- --test | grep '^ *--test *--', \