libbsd: fix compilation with musl 1.2.4
authorRobert Marko <robimarko@gmail.com>
Tue, 16 May 2023 08:48:28 +0000 (10:48 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 16 May 2023 12:31:14 +0000 (14:31 +0200)
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces so
just having _GNU_SOURCE defined is not enough anymore.

_LARGEFILE64_SOURCE has to be defined in the source, or CFLAGS can be used
to pass -D_LARGEFILE64_SOURCE to allow to keep using LFS64 definitions.

Fixes: fff878c5bcda ("toolchain/musl: update to 1.2.4")
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/libs/libbsd/Makefile

index 92c7054e3bd3fa2d681ceb584db81c54be6d9a07..1872e3ce30f3b536bbe3ac822592eb856ca4f7cd 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libbsd
 PKG_VERSION:=0.11.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://libbsd.freedesktop.org/releases
@@ -29,6 +29,8 @@ define Package/libbsd/description
  This library provides useful functions commonly found on BSD systems, and lacking on others like GNU systems, thus making it easier to port projects with strong BSD origins, without needing to embed the same code over and over again on each project.
 endef
 
+TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig