ar71xx: adding support for zyxel nbg460n/550n/550nh boards
authorGabor Juhos <juhosg@openwrt.org>
Sun, 18 Apr 2010 16:24:12 +0000 (16:24 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 18 Apr 2010 16:24:12 +0000 (16:24 +0000)
This patch adds support for the zyxel nbg460n/550n/550nh routers.
Currently this only works if a second stage bootloader is also flashed,
as the used switch needs extra initialization.

Signed-off-by: Michael Kurz <michi.kurz@googlemail.com>
SVN-Revision: 20990

target/linux/ar71xx/config-2.6.32
target/linux/ar71xx/config-2.6.33
target/linux/ar71xx/config-2.6.34
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-nbg460n.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h
target/linux/ar71xx/profiles/zyxel.mk [new file with mode: 0644]

index 417d718223092d99093218cf30886613fcfcb104..5c17220634ff13a60bfc52c9625c0be748dede14 100644 (file)
@@ -25,6 +25,7 @@ CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
 CONFIG_AR71XX_MACH_MZK_W04NU=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
+CONFIG_AR71XX_MACH_NBG460N=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_PB44=y
 CONFIG_AR71XX_MACH_PB92=y
index e147b014954021817e2db53b6dce902e67860767..ca49737f78588baaef25ebca607939c6a7dd81f0 100644 (file)
@@ -25,6 +25,7 @@ CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
 CONFIG_AR71XX_MACH_MZK_W04NU=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
+CONFIG_AR71XX_MACH_NBG460N=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_PB44=y
 CONFIG_AR71XX_MACH_PB92=y
index 549b7a8c7ae1461dba6fde54b2120364250bb3c8..7085b227bbb6d409eb48208506f3abd97a80c6a1 100644 (file)
@@ -24,6 +24,7 @@ CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
 CONFIG_AR71XX_MACH_MZK_W04NU=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
+CONFIG_AR71XX_MACH_NBG460N=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_PB44=y
 CONFIG_AR71XX_MACH_PB92=y
index 427eda2a17f51cf6d61844d7b023a12fb5ef2c5b..29448ac65be576d7eb8b9c4c7a7d182ea42f861a 100644 (file)
@@ -160,6 +160,14 @@ config AR71XX_MACH_MZK_W300NH
        select AR71XX_DEV_LEDS_GPIO
        default n
 
+config AR71XX_MACH_NBG460N
+       bool "Zyxel NBG460N/550N/550NH board support"
+       select AR71XX_DEV_M25P80
+       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_GPIO_BUTTONS
+       select AR71XX_DEV_LEDS_GPIO
+       default n
+       
 config AR71XX_MACH_TL_WR741ND
        bool "TP-LINK TL-WR741ND support"
        select AR71XX_DEV_M25P80
index e24df571f1314523a0519b54148066d164952f47..5c9e2c6df7c5cb0f84ef2725a2298ac0b3a66356 100644 (file)
@@ -35,6 +35,7 @@ obj-$(CONFIG_AR71XX_MACH_DIR_615_C1)  += mach-dir-615-c1.o
 obj-$(CONFIG_AR71XX_MACH_DIR_825_B1)   += mach-dir-825-b1.o
 obj-$(CONFIG_AR71XX_MACH_MZK_W04NU)    += mach-mzk-w04nu.o
 obj-$(CONFIG_AR71XX_MACH_MZK_W300NH)   += mach-mzk-w300nh.o
+obj-$(CONFIG_AR71XX_MACH_NBG460N)      += mach-nbg460n.o
 obj-$(CONFIG_AR71XX_MACH_PB42)         += mach-pb42.o
 obj-$(CONFIG_AR71XX_MACH_PB44)         += mach-pb44.o
 obj-$(CONFIG_AR71XX_MACH_PB92)         += mach-pb92.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-nbg460n.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-nbg460n.c
new file mode 100644 (file)
index 0000000..297f805
--- /dev/null
@@ -0,0 +1,215 @@
+/*
+ *  Zyxel NBG 460N/550N/550NH board support
+ *
+ *  Copyright (C) 2010 Michael Kurz <michi.kurz@googlemail.com>
+ *
+ *  based on mach-tl-wr1043nd.c
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/delay.h>
+#include <linux/rtl8366s.h>
+
+#include <linux/i2c.h>
+#include <linux/i2c-algo-bit.h>
+#include <linux/i2c-gpio.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "machtype.h"
+#include "devices.h"
+#include "dev-m25p80.h"
+#include "dev-ar913x-wmac.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+
+/* LEDs */
+#define NBG460N_GPIO_LED_WPS           3
+#define NBG460N_GPIO_LED_WAN           6
+#define NBG460N_GPIO_LED_POWER         14
+#define NBG460N_GPIO_LED_WLAN          15
+
+/* Buttons */
+#define NBG460N_GPIO_BTN_WPS           12
+#define NBG460N_GPIO_BTN_RESET         21
+#define NBG460N_BUTTONS_POLL_INTERVAL  20
+
+/* RTC chip PCF8563 I2C interface */
+#define NBG460N_GPIO_PCF8563_SDA       8
+#define NBG460N_GPIO_PCF8563_SCK       7
+
+/* Switch configuration I2C interface */
+#define NBG460N_GPIO_RTL8366_SDA       16
+#define NBG460N_GPIO_RTL8366_SCK       18
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition nbg460n_partitions[] = {
+       {
+               .name           = "Bootbase",
+               .offset         = 0,
+               .size           = 0x010000,
+       } , {
+               .name           = "U-Boot Config",
+               .offset         = 0x010000,
+               .size           = 0x030000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "U-Boot",
+               .offset         = 0x040000,
+               .size           = 0x030000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "firmware",
+               .offset         = 0x070000,
+               .size           = 0x380000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "CalibData",
+               .offset         = 0x3f0000,
+               .size           = 0x010000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data nbg460n_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+        .parts          = nbg460n_partitions,
+        .nr_parts       = ARRAY_SIZE(nbg460n_partitions),
+#endif
+};
+
+static struct gpio_led nbg460n_leds_gpio[] __initdata = {
+       {
+               .name           = "nbg460n:green:power",
+               .gpio           = NBG460N_GPIO_LED_POWER,
+               .active_low     = 0,
+               .default_trigger = "default-on",
+       }, {
+               .name           = "nbg460n:green:wps",
+               .gpio           = NBG460N_GPIO_LED_WPS,
+               .active_low     = 0,
+       }, {
+               .name           = "nbg460n:green:wlan",
+               .gpio           = NBG460N_GPIO_LED_WLAN,
+               .active_low     = 0,
+       }, {
+               /* Not really for controlling the LED,
+                  when set low the LED blinks uncontrollable  */
+               .name           = "nbg460n:green:wan",
+               .gpio           = NBG460N_GPIO_LED_WAN,
+               .active_low     = 0,
+       }
+};
+
+static struct gpio_button nbg460n_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = BTN_0,
+               .threshold      = 5,
+               .gpio           = NBG460N_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = BTN_1,
+               .threshold      = 5,
+               .gpio           = NBG460N_GPIO_BTN_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct i2c_gpio_platform_data nbg460n_i2c_device_platdata = {
+       .sda_pin        = NBG460N_GPIO_PCF8563_SDA,
+       .scl_pin        = NBG460N_GPIO_PCF8563_SCK,
+       .udelay         = 10,
+};
+
+static struct platform_device nbg460n_i2c_device = {
+       .name           = "i2c-gpio",
+       .id             = -1,
+       .num_resources  = 0,
+       .resource       = NULL,
+       .dev            = {
+               .platform_data  = &nbg460n_i2c_device_platdata,
+       },
+};
+
+static struct i2c_board_info nbg460n_i2c_devs[] __initdata = {
+       {
+               I2C_BOARD_INFO("pcf8563", 0x51),
+       },
+};
+
+static void __devinit nbg460n_i2c_init(void)
+{
+       /* The gpio interface */
+       platform_device_register(&nbg460n_i2c_device);
+       /* I2C devices */
+       i2c_register_board_info(0, nbg460n_i2c_devs,
+                               ARRAY_SIZE(nbg460n_i2c_devs));
+}
+
+
+static struct rtl8366s_platform_data nbg460n_rtl8366s_data = {
+       .gpio_sda        = NBG460N_GPIO_RTL8366_SDA,
+       .gpio_sck        = NBG460N_GPIO_RTL8366_SCK,
+};
+
+static struct platform_device nbg460n_rtl8366s_device = {
+       .name           = RTL8366S_DRIVER_NAME,
+       .id             = -1,
+       .dev = {
+               .platform_data  = &nbg460n_rtl8366s_data,
+       }
+};
+
+static void __init nbg460n_setup(void)
+{
+       /* end of bootloader sector contains mac address*/
+       u8 *mac = (u8 *) KSEG1ADDR(0x1fc0fff8);
+       /* last sector contains wlan calib data */
+       u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       ar71xx_set_mac_base(mac);
+
+       /* LAN Port */
+       ar71xx_eth0_data.mii_bus_dev = &nbg460n_rtl8366s_device.dev;
+       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ar71xx_eth0_data.speed = SPEED_1000;
+       ar71xx_eth0_data.duplex = DUPLEX_FULL;
+
+       /* WAN Port */
+       ar71xx_eth1_data.mii_bus_dev = &nbg460n_rtl8366s_device.dev;
+       ar71xx_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ar71xx_eth1_data.phy_mask = 0x10;
+
+       ar71xx_add_device_eth(0);
+       ar71xx_add_device_eth(1);
+
+       /* register the switch phy */
+       platform_device_register(&nbg460n_rtl8366s_device);
+
+       /* register flash */
+       ar71xx_add_device_m25p80(&nbg460n_flash_data);
+
+       ar913x_add_device_wmac(eeprom, mac);
+
+       /* register RTC chip */
+       nbg460n_i2c_init();
+
+       ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(nbg460n_leds_gpio),
+                                       nbg460n_leds_gpio);
+
+       ar71xx_add_device_gpio_buttons(-1, NBG460N_BUTTONS_POLL_INTERVAL,
+                                       ARRAY_SIZE(nbg460n_gpio_buttons),
+                                       nbg460n_gpio_buttons);
+}
+
+MIPS_MACHINE(AR71XX_MACH_NBG460N, "NBG460N", "Zyxel NBG460N/550N/550NH", nbg460n_setup);
index a8679d97c663e598414e6d3b093baa331e58e49b..15e5b96663b265c4f7fb776edc9b0dd609d3db03 100644 (file)
@@ -35,6 +35,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_PB92,       /* Atheros PB92 */
        AR71XX_MACH_MZK_W04NU,  /* Planex MZK-W04NU */
        AR71XX_MACH_MZK_W300NH, /* Planex MZK-W300NH */
+       AR71XX_MACH_NBG460N,    /* Zyxel NBG460N/550N/550NH */
        AR71XX_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
        AR71XX_MACH_TL_WR741ND, /* TP-LINK TL-WR741ND */
        AR71XX_MACH_TL_WR841N_V1, /* TP-LINK TL-WR841N v1 */
diff --git a/target/linux/ar71xx/profiles/zyxel.mk b/target/linux/ar71xx/profiles/zyxel.mk
new file mode 100644 (file)
index 0000000..73ae4e2
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NBG_460N_550N_550NH
+       NAME:=Zyxel NBG 460N/550N/550NH
+       PACKAGES:=kmod-ath9k swconfig
+endef
+
+define Profile/NBG_460N_550N_550NH/Description
+       Package set optimized for the Zyxel NBG 460N/550N/550NH Routers.
+endef
+
+$(eval $(call Profile,NBG_460N_550N_550NH))