ipset: update to 7.16
authorNick Hainke <vincent@systemli.org>
Tue, 22 Nov 2022 07:58:09 +0000 (08:58 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Nov 2022 11:58:33 +0000 (12:58 +0100)
Release Notes:
https://lore.kernel.org/netfilter-devel/d65fe5d8-d5ea-ef7-102d-aa1d15bb4d69@netfilter.org/T/#u

Patch "0001-lib-ipset-fix-printf-warning.patch" replaced upstream by:
http://git.netfilter.org/ipset/commit/?id=e39e3466d2d38cdfe83447f391b550e607bc3ce8

Remove upstreamed:
- 0002-Fix-IPv6-sets-nftables-translation.patch

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/network/utils/ipset/Makefile
package/network/utils/ipset/patches/0001-lib-ipset-fix-printf-warning.patch [deleted file]
package/network/utils/ipset/patches/0002-Fix-IPv6-sets-nftables-translation.patch [deleted file]

index f6ec5cf679c0b2408e0cd0e44dd361556b4e931e..be407f016be9a580e7b3c72d7602e0972a56daca 100644 (file)
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ipset
-PKG_VERSION:=7.15
-PKG_RELEASE:=2
+PKG_VERSION:=7.16
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://ipset.netfilter.org
-PKG_HASH:=0a5545aaadb640142c1f888d366a78ddf8724799967fa20686a70053bd621751
+PKG_HASH:=87b1d9cdf4a1de3d1d0671e7da33e111eb65087e65ad75268b22bf13f0f296d0
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/ipset/patches/0001-lib-ipset-fix-printf-warning.patch b/package/network/utils/ipset/patches/0001-lib-ipset-fix-printf-warning.patch
deleted file mode 100644 (file)
index 90dfaca..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib/ipset.c
-+++ b/lib/ipset.c
-@@ -1847,7 +1847,7 @@ static int ipset_xlate(struct ipset *ips
-               return -1;
-       case IPSET_CMD_LIST:
-               if (!set) {
--                      printf("list sets %s\n",
-+                      printf("list sets %s %s\n",
-                              ipset_xlate_family(family), table);
-               } else {
-                       printf("list set %s %s %s\n",
diff --git a/package/network/utils/ipset/patches/0002-Fix-IPv6-sets-nftables-translation.patch b/package/network/utils/ipset/patches/0002-Fix-IPv6-sets-nftables-translation.patch
deleted file mode 100644 (file)
index 6b29f26..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-From 50ef784944c60cd291970c47e4b831ff7ef9c923 Mon Sep 17 00:00:00 2001
-From: Pablo Neira Ayuso <pablo@netfilter.org>
-Date: Mon, 28 Feb 2022 20:02:17 +0100
-Subject: [PATCH] Fix IPv6 sets nftables translation
-
-The parser assumes the set is an IPv4 ipset because IPSET_OPT_FAMILY is
-not set.
-
- # ipset-translate restore < ./ipset-mwan3_set_connected_ipv6.dump
- add table inet global
- add set inet global mwan3_connected_v6 { type ipv6_addr; flags interval; }
- flush set inet global mwan3_connected_v6
- ipset v7.15: Error in line 4: Syntax error: '64' is out of range 0-32
-
-Remove ipset_xlate_type_get(), call ipset_xlate_set_get() instead to
-obtain the set type and family.
-
-Reported-by: Florian Eckert <fe@dev.tdt.de>
-Fixes: 325af556cd3a ("add ipset to nftables translation infrastructure")
-Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
----
- lib/ipset.c             | 24 ++++++++++--------------
- tests/xlate/xlate.t     |  2 ++
- tests/xlate/xlate.t.nft |  2 ++
- 3 files changed, 14 insertions(+), 14 deletions(-)
-
---- a/lib/ipset.c
-+++ b/lib/ipset.c
-@@ -949,18 +949,6 @@ ipset_xlate_set_get(struct ipset *ipset,
-       return NULL;
- }
--static const struct ipset_type *ipset_xlate_type_get(struct ipset *ipset,
--                                                   const char *name)
--{
--      const struct ipset_xlate_set *set;
--
--      set = ipset_xlate_set_get(ipset, name);
--      if (!set)
--              return NULL;
--
--      return set->type;
--}
--
- static int
- ipset_parser(struct ipset *ipset, int oargc, char *oargv[])
- {
-@@ -1282,8 +1270,16 @@ ipset_parser(struct ipset *ipset, int oa
-               if (!ipset->xlate) {
-                       type = ipset_type_get(session, cmd);
-               } else {
--                      type = ipset_xlate_type_get(ipset, arg0);
--                      ipset_session_data_set(session, IPSET_OPT_TYPE, type);
-+                      const struct ipset_xlate_set *xlate_set;
-+
-+                      xlate_set = ipset_xlate_set_get(ipset, arg0);
-+                      if (xlate_set) {
-+                              ipset_session_data_set(session, IPSET_OPT_TYPE,
-+                                                     xlate_set->type);
-+                              ipset_session_data_set(session, IPSET_OPT_FAMILY,
-+                                                     &xlate_set->family);
-+                              type = xlate_set->type;
-+                      }
-               }
-               if (type == NULL)
-                       return ipset->standard_error(ipset, p);
---- a/tests/xlate/xlate.t
-+++ b/tests/xlate/xlate.t
-@@ -53,3 +53,5 @@ create bp1 bitmap:port range 1-1024
- add bp1 22
- create bim1 bitmap:ip,mac range 1.1.1.0/24
- add bim1 1.1.1.1,aa:bb:cc:dd:ee:ff
-+create hn6 hash:net family inet6
-+add hn6 fe80::/64
---- a/tests/xlate/xlate.t.nft
-+++ b/tests/xlate/xlate.t.nft
-@@ -54,3 +54,5 @@ add set inet global bp1 { type inet_serv
- add element inet global bp1 { 22 }
- add set inet global bim1 { type ipv4_addr . ether_addr; }
- add element inet global bim1 { 1.1.1.1 . aa:bb:cc:dd:ee:ff }
-+add set inet global hn6 { type ipv6_addr; flags interval; }
-+add element inet global hn6 { fe80::/64 }