ext2 images need to wait for /dev/sda2 to appear before attempting to mount it, fixes...
authorFlorian Fainelli <florian@openwrt.org>
Thu, 29 Oct 2009 23:34:39 +0000 (23:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 29 Oct 2009 23:34:39 +0000 (23:34 +0000)
SVN-Revision: 18215

target/linux/olpc/image/Makefile

index eb1bedd0a05707d2d420e39e376c45e81d0aeea0..f60b76e204f96cd961e67f0b3f90be7f5c9adafc 100644 (file)
@@ -27,7 +27,7 @@ ifeq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),y)
   endef
 
   define Image/cmdline/ext2
-    root=$(ROOTPART) rootfstype=ext2
+    root=$(ROOTPART) rootfstype=ext2 rootwait
   endef
 
   define Image/Build/bootscript