ath79: WNDR4300: increase kernel partition to 4M
authorMichal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
Sun, 22 Dec 2019 20:53:29 +0000 (21:53 +0100)
committerJohn Crispin <john@phrozen.org>
Wed, 15 Jan 2020 19:55:42 +0000 (20:55 +0100)
Increase kernel partition from 2 MiB to 4 MiB for Netgear WNDR routers
with NAND flash. Change affects following devices:
 * Netgear WNDR3700 v4
 * Netgear WNDR4300

Signed-off-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
target/linux/ath79/dts/ar9344_netgear_wndr.dtsi
target/linux/ath79/image/nand.mk

index 38dd052f5f5e8486254ad1bdc5085908c9890146..dd212c0d88041589b605e60202536aefe6560e41 100644 (file)
                        #address-cells = <1>;
                        #size-cells = <1>;
 
-                       ubi@8c0000 {
+                       ubi@ac0000 {
                                label = "ubi";
-                               reg = <0x0 0x7700000>;
+                               reg = <0x0 0x7500000>;
                        };
                };
        };
 
                kernel@6c0000 {
                        label = "kernel";
-                       reg = <0x6c0000 0x200000>;
+                       reg = <0x6c0000 0x400000>;
                };
 
-               ubipart0: partition@8c0000 {
+               ubipart0: partition@ac0000 {
                        label = "ubipart0";
-                       reg = <0x8c0000 0x1700000>;
+                       reg = <0xac0000 0x1500000>;
                };
 
                partition@6c0000 {
index 00479e4eb5e8744b1930c85aa2cb767a21b8e2c9..d2018afb616133851082d7d9289d0ecf243b06f0 100644 (file)
@@ -114,7 +114,7 @@ TARGET_DEVICES += glinet_gl-ar750s-nor
 define Device/netgear_ath79_nand
   DEVICE_VENDOR := NETGEAR
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
-  KERNEL_SIZE := 2048k
+  KERNEL_SIZE := 4096k
   BLOCKSIZE := 128k
   PAGESIZE := 2048
   IMAGE_SIZE := 25600k