linux-firmware: package EIP197 mini firmware
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Thu, 9 Jul 2020 19:16:15 +0000 (21:16 +0200)
committerPetr Štetiar <ynezz@true.cz>
Sat, 11 Jul 2020 11:33:28 +0000 (13:33 +0200)
Quoting part of original message from eefb5f741015 commit in
linux-firmware repository:

This adds the "minifw" version of the EIP197 firmware, which the inside-
secure driver will use as a fallback if the original full-featured
firmware cannot be found. This allows for using the inside-secure driver
and hardware without access to "official" firmware only available under
NDA.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
package/firmware/linux-firmware/misc.mk [new file with mode: 0644]
package/kernel/linux/modules/crypto.mk

diff --git a/package/firmware/linux-firmware/misc.mk b/package/firmware/linux-firmware/misc.mk
new file mode 100644 (file)
index 0000000..d0956f7
--- /dev/null
@@ -0,0 +1,9 @@
+Package/eip197-mini-firmware = $(call Package/firmware-default,Inside Secure EIP197 mini firmware)
+define Package/eip197-mini-firmware/install
+       $(INSTALL_DIR) $(1)/lib/firmware/inside-secure/eip197_minifw
+       $(INSTALL_DATA) \
+               $(PKG_BUILD_DIR)/inside-secure/eip197_minifw/ifpp.bin \
+               $(PKG_BUILD_DIR)/inside-secure/eip197_minifw/ipue.bin \
+               $(1)/lib/firmware/inside-secure/eip197_minifw
+endef
+$(eval $(call BuildPackage,eip197-mini-firmware))
index 900172179297767009a250c2b183f4623ee185d1..48777764a8fa3266df689d30758100c1aef9e3d1 100644 (file)
@@ -377,7 +377,7 @@ $(eval $(call KernelPackage,crypto-hw-padlock))
 
 define KernelPackage/crypto-hw-safexcel
   TITLE:= MVEBU SafeXcel Crypto Engine module
-  DEPENDS:=@!LINUX_4_14 @(TARGET_mvebu_cortexa53||TARGET_mvebu_cortexa72) \
+  DEPENDS:=@!LINUX_4_14 @(TARGET_mvebu_cortexa53||TARGET_mvebu_cortexa72) +eip197-mini-firmware \
        +kmod-crypto-authenc +kmod-crypto-md5 +kmod-crypto-hmac +kmod-crypto-sha256 +kmod-crypto-sha512
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
@@ -392,9 +392,11 @@ MVEBU's EIP97 and EIP197 Cryptographic Engine driver designed by
 Inside Secure. This is found on Marvell Armada 37xx/7k/8k SoCs.
 
 Particular version of these IP (EIP197B and EIP197D) require firmware.
-Unfortunately it's not freely available and needs signed Non-Disclosure
-Agreement (NDA) with Marvell. For those who have signed NDA the firmware can be
-obtained at https://extranet.marvell.com.
+The mini firmware package provides limited functionality, for most operations
+a full-featured firmware is required. Unfortunately the "full" firmware is not
+freely available and needs signed Non-Disclosure Agreement (NDA) with Marvell.
+For those who have signed NDA the firmware can be obtained at
+https://extranet.marvell.com.
 endef
 
 $(eval $(call KernelPackage,crypto-hw-safexcel))