Fix patch
authorLars-Peter Clausen <lars@metafoo.de>
Fri, 29 Oct 2010 06:59:46 +0000 (06:59 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Fri, 29 Oct 2010 06:59:46 +0000 (06:59 +0000)
SVN-Revision: 23702

target/linux/kirkwood/patches/200-iconnect.patch

index 1be792bf498dcfef461d140c37806c0fdfd4bbc2..3bc814067ef6a3a4f7c95b9c707cf4f9a56afdaf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-kirkwood/Makefile
 +++ b/arch/arm/mach-kirkwood/Makefile
-@@ -8,6 +8,7 @@
+@@ -8,6 +8,7 @@ obj-$(CONFIG_MACH_SHEEVAPLUG)          += sheeva
  obj-$(CONFIG_MACH_DOCKSTAR)           += dockstar-setup.o
  obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG)   += sheevaplug-setup.o
  obj-$(CONFIG_MACH_GURUPLUG)           += guruplug-setup.o
@@ -9,8 +9,8 @@
  obj-$(CONFIG_MACH_TS41X)              += ts41x-setup.o tsx1x-common.o
  obj-$(CONFIG_MACH_OPENRD)             += openrd-setup.o
 --- a/arch/arm/mach-kirkwood/Kconfig
-+++ b/arch/arm/mach-kirkwood/Kconfig 
-@@ -105,6 +105,12 @@
++++ b/arch/arm/mach-kirkwood/Kconfig
+@@ -105,6 +105,12 @@ config MACH_DOCKSTAR
          Say 'Y' here if you want your kernel to support the
          Seagate FreeAgent DockStar.
  
@@ -24,7 +24,7 @@
  
  endif
 --- a/arch/arm/mach-kirkwood/mpp.h
-+++ b/arch/arm/mach-kirkwood/mpp.h 
++++ b/arch/arm/mach-kirkwood/mpp.h
 @@ -103,6 +103,7 @@
  #define MPP11_SATA0_ACTn      MPP( 11, 0x5, 0, 1, 0,   1,   1,   1    )
  
@@ -33,9 +33,9 @@
  #define MPP12_SD_CLK          MPP( 12, 0x1, 0, 1, 1,   1,   1,   1    )
  
  #define MPP13_GPIO            MPP( 13, 0x0, 1, 1, 1,   1,   1,   1    )
---- /dev/null 
-+++ b/arch/arm/mach-kirkwood/iconnect-setup.c 
-@@ -1,0 +1,190 @@
+--- /dev/null
++++ b/arch/arm/mach-kirkwood/iconnect-setup.c
+@@ -0,0 +1,190 @@
 +/*
 + * arch/arm/mach-kirkwood/iconnect-setup.c
 + *