base-files: introduce service_kill() into functions.sh - a convenience wrapper for...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Sep 2010 14:03:32 +0000 (14:03 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Sep 2010 14:03:32 +0000 (14:03 +0000)
SVN-Revision: 23087

package/base-files/Makefile
package/base-files/files/etc/functions.sh

index bdaf53c77102f5ca518c22ada16dfcb4fe85e5ea..7abcd8b2b58d415fa2e30ef9af05888f32949636 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=54
+PKG_RELEASE:=55
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index d5ffc13535df8318100857242ec406dea301af62..c5df49970bf53f6d85d7e884488324549d148b3d 100755 (executable)
@@ -275,4 +275,21 @@ uci_apply_defaults() {
        uci commit
 }
 
+service_kill() {
+       local name="${1}"
+       local pid="${2:-$(pidof "$name")}"
+       local grace="${3:-5}"
+
+       [ -f "$pid" ] && pid="$(head -n1 "$pid" 2>/dev/null)"
+
+       for pid in $pid; do
+               [ -d "/proc/$pid" ] || continue
+               local try=0
+               kill -TERM $pid 2>/dev/null && \
+                       while grep -qs "$name" "/proc/$pid/cmdline" && [ $((try++)) -lt $grace ]; do sleep 1; done
+               kill -KILL $pid 2>/dev/null && \
+                       while grep -qs "$name" "/proc/$pid/cmdline"; do sleep 1; done
+       done
+}
+
 [ -z "$IPKG_INSTROOT" -a -f /lib/config/uci.sh ] && . /lib/config/uci.sh