uboot-imx: fix wrong make flags overriding
authorPetr Štetiar <ynezz@true.cz>
Sat, 28 May 2022 12:18:06 +0000 (14:18 +0200)
committerPetr Štetiar <ynezz@true.cz>
Sat, 28 May 2022 12:32:40 +0000 (14:32 +0200)
Buidbots are currently choking on the following compile error:

 In file included from tools/aisimage.c:9:
 include/image.h:1133:12: fatal error: openssl/evp.h: No such file or directory
  #  include <openssl/evp.h>
             ^~~~~~~~~~~~~~~
 compilation terminated.

This is caused by a complete overriding of make flags which are provided
correctly in `UBOOT_MAKE_FLAGS` variable, but currently overriden
instead of extended. This then leads to the usage of build host include
dirs, which are not available.

Fix it by extending `UBOOT_MAKE_FLAGS` variable in all device recipes.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/boot/uboot-imx/Makefile

index 63f145798d6e4b91fbc8c3bc745faf3c59c96dfa..305d127557fb66559d8e1a7f969bcc657cfa1f32 100644 (file)
@@ -23,7 +23,7 @@ endef
 define U-Boot/apalis_imx6
   NAME:=Toradex Apalis
   UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
-  UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+  UBOOT_MAKE_FLAGS+=SPL u-boot.img u-boot-with-spl.imx
   BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=toradex_apalis
 endef
@@ -31,7 +31,7 @@ endef
 define U-Boot/mx6cuboxi
   NAME:=SolidRun Cubox-i boards
   UBOOT_IMAGE:=SPL u-boot-dtb.img
-  UBOOT_MAKE_FLAGS:=SPL u-boot-dtb.img
+  UBOOT_MAKE_FLAGS+=SPL u-boot-dtb.img
   BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=solidrun_cubox-i
 endef