bmips: bump LZMA Loader address
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Fri, 9 Jun 2023 17:48:42 +0000 (19:48 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Fri, 9 Jun 2023 17:48:42 +0000 (19:48 +0200)
This allows booting bigger ramdisk images via TFTP at the cost of breaking 32M
RAM compatibility, but those devices have been unable to boot ramdisks on this
target for some time anyway due to not having enough RAM.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bmips/image/Makefile

index f86e46e0b95526325dbec00a0955487898555352..b5e3098fe75aa5c1e768e8cca4c46c09fa209ce9 100644 (file)
@@ -5,7 +5,7 @@ include $(INCLUDE_DIR)/image.mk
 
 KERNEL_LOADADDR := 0x80010000          # RAM start + 64K
 LOADER_ENTRY := 0x80a00000             # RAM start + 10M, for relocate
-LZMA_TEXT_START := 0x81800000          # RAM start + 24M
+LZMA_TEXT_START := 0x82000000          # RAM start + 32M
 
 DEVICE_VARS += CFE_BOARD_ID CFE_EXTRAS
 DEVICE_VARS += CFE_PART_FLAGS CFE_PART_ID