ramips: allow custom trx magic for Arcadyan
authorMikhail Zhilkin <csharper2005@gmail.com>
Thu, 28 Apr 2022 18:24:07 +0000 (18:24 +0000)
committerPetr Štetiar <ynezz@true.cz>
Tue, 16 Aug 2022 14:04:55 +0000 (16:04 +0200)
This commit:
1. Renames beeline-trx recipe in mt7621.mk to arcadyan-trx. The recipe
   is necessary for:
   - MTS WG430223 (Arcadyan WG430223)
   - Beeline Smartbox Flash (Arcadyan WG443223)
2. Allows specify custom trx magic which is different for the routers
   mentined above.

Signed-off-by: Mikhail Zhilkin <csharper2005@gmail.com>
(cherry picked from commit 109c503bee9aed34ffb485a29af1e2ec6f3bb6b1)
[fix merging conflict in mt7621.mk]
Signed-off-by: Mikhail Zhilkin <csharper2005@gmail.com>
target/linux/ramips/image/mt7621.mk

index 860b33d1dd95e860ad7ef1806a78eab51e2c3992..5f6ef8cb763785faea43aa973267fada4e29a333 100644 (file)
@@ -9,9 +9,10 @@ DEFAULT_SOC := mt7621
 KERNEL_DTB += -d21
 DEVICE_VARS += ELECOM_HWNAME LINKSYS_HWNAME
 
-define Build/beeline-trx
+define Build/arcadyan-trx
        echo -ne "hsqs" > $@.hsqs
-       $(STAGING_DIR_HOST)/bin/otrx create $@.trx -M 0x746f435d -f $@ \
+       $(eval trx_magic=$(word 1,$(1)))
+       $(STAGING_DIR_HOST)/bin/otrx create $@.trx -M $(trx_magic) -f $@ \
                -a 0x20000 -b 0x420000 -f $@.hsqs -a 1000
        mv $@.trx $@
        dd if=/dev/zero bs=1024 count=1 >> $@.tail
@@ -255,7 +256,7 @@ define Device/beeline_smartbox-flash
   BLOCKSIZE := 128k
   PAGESIZE := 2048
   KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | \
-       uImage none | beeline-trx | pad-to $$(KERNEL_SIZE)
+       uImage none | arcadyan-trx 0x746f435d | pad-to $$(KERNEL_SIZE)
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | \
        uImage none
   IMAGES += factory.trx