pcre: clean up Makefile line order
authorDaniel Golle <daniel@makrotopia.org>
Fri, 14 Aug 2020 01:38:21 +0000 (02:38 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 14 Aug 2020 01:42:25 +0000 (02:42 +0100)
The most recent patch added add lines in one block instead of in the
appropriate places to keep Makefiles in consistent style. Fix that.

Fixes: ff02e1561f ("pcre: add host variant of libpcre")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/libs/pcre/Makefile

index 36556141693b83efa747ef0326ae1a128e0b75ea..bf3f733a5c4cd6feaf6e314a6757a49829acd935 100644 (file)
@@ -29,6 +29,7 @@ PKG_CONFIG_DEPENDS:=\
 
 include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/libpcre/default
   SECTION:=libs
@@ -61,7 +62,6 @@ define Package/libpcrecpp
   DEPENDS:=+libpcre $(CXX_DEPENDS)
 endef
 
-include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += \
        --enable-utf8 \
@@ -70,9 +70,6 @@ HOST_CONFIGURE_ARGS += \
        --with-match-limit-recursion=16000 \
        --enable-cpp
 
-$(eval $(call HostBuild))
-
-
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
@@ -129,3 +126,4 @@ $(eval $(call BuildPackage,libpcre))
 $(eval $(call BuildPackage,libpcre16))
 $(eval $(call BuildPackage,libpcre32))
 $(eval $(call BuildPackage,libpcrecpp))
+$(eval $(call HostBuild))