ramips: Derive DTS name from device name in Makefile
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 3 Jul 2019 21:22:22 +0000 (23:22 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 10 Jul 2019 15:36:29 +0000 (17:36 +0200)
This will automatically derive the DTS name as in ath79 and thus
makes specifying DTS for every device obsolete.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---

This patch only introduces the mechanism and is then followed by
commits with renames and Makefile adjustments per subtarget.

Eventually, those can be all squashed into a single commit or left
as they are to enhance overview.

target/linux/ramips/image/Makefile

index 07251aebbad781592d121c244f12c977cdfc2aba..181c82587397e770019c390438601cbfc4e72d59 100644 (file)
@@ -23,8 +23,9 @@ KERNEL_DTB = kernel-bin | append-dtb | lzma
 define Device/Default
   PROFILES = Default
   KERNEL := $(KERNEL_DTB) | uImage lzma
+  MTK_SOC :=
   DEVICE_DTS_DIR := ../dts
-  DEVICE_DTS = $$(DTS)
+  DEVICE_DTS = $$(MTK_SOC)_$(1)
   IMAGES := sysupgrade.bin
   IMAGE_SIZE := $(ralink_default_fw_size_8M)
   SUPPORTED_DEVICES := $(subst _,$(comma),$(1))