rules.mk: replace iremap when using GCC 8
authorSyrone Wong <wong.syrone@gmail.com>
Thu, 21 Jun 2018 15:08:11 +0000 (23:08 +0800)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:32:20 +0000 (17:32 +0100)
The original -iremap is replaced by -fmacro-prefix-map in GCC 8

Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
(backported from da9d760ea1c0450e9e6b1c0cdd5331e633c75887)

rules.mk

index 15b330c792615156d9bdb65fa847ce9fb2c80164..78792d1c75363f542259bed9ab71f09653e8e947 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -141,6 +141,10 @@ endif
 
 ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_GCC_VERSION_4_8),$(CONFIG_TARGET_uml)),)
   iremap = -iremap$(1):$(2)
+  # just overwrite iremap for GCC 8.1 and higher to keep backward compatibility
+  ifeq ($(CONFIG_GCC_VERSION_8),y)
+    iremap = -fmacro-prefix-map=$(1)=$(2)
+  endif
 endif
 
 PACKAGE_DIR:=$(BIN_DIR)/packages