ipq40xx: fix image building for ZTE MF287 series
authorAndreas Böhler <dev@aboehler.at>
Tue, 12 Sep 2023 17:57:55 +0000 (19:57 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 18 Sep 2023 09:50:08 +0000 (11:50 +0200)
For the ZTE MF287 series, a special recovery image is built. The Makefile
worked fine on snapshot, but created corrupt images on the 23.05 images.
By using the appropriate variable, this should be fixed.

Signed-off-by: Andreas Böhler <dev@aboehler.at>
(cherry picked from commit a9cc3708e0c3c4869711a9ba4b9c1437ed250721)

target/linux/ipq40xx/image/generic.mk

index 7f4806b63d5040e447fc1e6546778dd823bf372a..08cbd63b3c88d78e7ea9f64b9b193537c2b72ba4 100644 (file)
@@ -1172,7 +1172,7 @@ define Device/zte_mf287_common
 #      exploit for the web interface
        IMAGES += factory.bin recovery.bin
        IMAGE/factory.bin  := append-ubi
-       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/openwrt-$$(BOARD)$$(if $$(SUBTARGET),-$$(SUBTARGET))-$$(DEVICE_NAME)-initramfs-zImage.itb rootfs=$$$$@ | append-metadata
+       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE) rootfs=$$$$@ | append-metadata
 endef
 
 define Device/zte_mf287plus