treewide: https for downloads.openwrt.org sources
authorPaul Spooren <mail@aparcar.org>
Tue, 25 Aug 2020 20:52:22 +0000 (10:52 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 31 Aug 2020 10:26:10 +0000 (11:26 +0100)
Instead of using http and https for source downloads from
downloads.openwrt.org, always use https for it's better security.

Signed-off-by: Paul Spooren <mail@aparcar.org>
package/firmware/b43legacy-firmware/Makefile
package/kernel/broadcom-wl/Makefile
package/kernel/lantiq/ltq-vmmc/Makefile
tools/lzma-old/Makefile
tools/lzma/Makefile

index 07c584f0143505b1da712960de43e3297def9b67..9b9c0070b282f5553812152ed21ed6871f120b88 100644 (file)
@@ -12,7 +12,7 @@ PKG_VERSION:=3.130.20.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=wl_apsta-$(PKG_VERSION).o
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
+PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
 PKG_HASH:=7dba610b1d96dd14e901bcbce14cd6ecd1b1ac6f5c0035b0d6b6dc46a7c3ef90
 
 include $(INCLUDE_DIR)/package.mk
index 1e1447cde566287862994dd80362cb67dc70b866..661c7f0589794e303c41dd6d9b2e9706560af596 100644 (file)
@@ -13,7 +13,7 @@ PKG_VERSION:=5.10.56.27.3
 PKG_RELEASE:=10
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
+PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
 
 ifeq ($(ARCH),mipsel)
 PKG_HASH:=26a8c370f48fc129d0731cfd751c36cae1419b0bc8ca35781126744e60eae009
index def676b833c7db4d1eb949cb863a6bb24146b2c9..586d9f6c75ebc8b3110d9a82f4630339f0f074cf 100644 (file)
@@ -14,7 +14,7 @@ PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_HASH:=707f515eb727c032418c4da67d7e86884bb56cdc2a606e8f6ded6057d8767e57
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_SOURCE_URL:=https://mirror2.openwrt.org/sources
 PKG_MAINTAINER:=John Crispin <john@phrozen.org>
 
 PKG_CHECK_FORMAT_SECURITY:=0
index 5204127a8097039769c2e89e118425a1f126ffbd..4ccd336ed0342b2b58ceb5e905617d1cdbe9fa16 100644 (file)
@@ -10,7 +10,7 @@ PKG_NAME:=lzma-old
 PKG_VERSION:=4.32
 
 PKG_SOURCE:=lzma-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
 PKG_HASH:=49053e4bb5e0646a841d250d9cb81f7714f5fff04a133216c4748163567acc3d
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/lzma-$(PKG_VERSION)
index 7d2669e95f3f71f59382583690b70fcc341a7205..04c427a3a94301aec001e3bbd181291413878d78 100644 (file)
@@ -10,7 +10,7 @@ PKG_NAME:=lzma
 PKG_VERSION:=4.65
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
 PKG_HASH:=dcbdb5f4843eff638e4a5e8be0e2486a3c5483df73c70823618db8e66f609ec2
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)