prereq-build: replace the openssl command check with a check for headers
authorFelix Fietkau <nbd@openwrt.org>
Mon, 20 Oct 2014 09:17:56 +0000 (09:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 20 Oct 2014 09:17:56 +0000 (09:17 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 42995

include/prereq-build.mk

index cb23f8564716bf6586c078d5ae4bfa15f6c47bb8..4a87c9211aff402f58ba34bc62661130030835a9 100644 (file)
@@ -168,8 +168,13 @@ $(eval $(call RequireCommand,svn, \
        Please install the subversion client. \
 ))
 
-$(eval $(call RequireCommand,openssl, \
-       Please install openssl. \
+define Require/openssl
+       echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
+               gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl
+endef
+
+$(eval $(call Require,openssl, \
+       Please install openssl (with development headers) \
 ))
 
 define Require/gnu-find