kernel: bump 4.14 to 4.14.137
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 7 Aug 2019 11:55:05 +0000 (13:55 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 9 Aug 2019 16:32:38 +0000 (18:32 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.14/950-0280-gpiolib-Don-t-prevent-IRQ-usage-of-output-GPIOs.patch
target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch
target/linux/generic/backport-4.14/011-kbuild-export-SUBARCH.patch
target/linux/generic/hack-4.14/207-disable-modorder.patch
target/linux/generic/hack-4.14/220-gc_sections.patch
target/linux/generic/pending-4.14/201-extra_optimization.patch

index a063590c807e05ef52011c6a240ac40b2faad3ff..ae5ad08f9afedb80782616f2f44ce7775c8cfd26 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .136
+LINUX_VERSION-4.14 = .137
 
-LINUX_KERNEL_HASH-4.14.136 = 268dff959216e59437a8f9db7c2cea3a1ada8a4c72232dc5b7f83ecca12bdf70
+LINUX_KERNEL_HASH-4.14.137 = 93f8e91329300f325a5b4dd9de1f51c0b1bf9591dfd2274044c2f70f96bae228
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 60e885800568892b772e770ac5c3faf1e1579253..830523e3bcc45cd4a1a7356edd1adb43b40c5c4e 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  /* Device and char device-related information */
  static DEFINE_IDA(gpio_ida);
  static dev_t gpio_devt;
-@@ -2303,7 +2305,7 @@ static int _gpiod_direction_output_raw(s
+@@ -2305,7 +2307,7 @@ static int _gpiod_direction_output_raw(s
        int ret;
  
        /* GPIOs used for IRQs shall not be set as output */
@@ -35,7 +35,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
                gpiod_err(desc,
                          "%s: tried to set a GPIO tied to an IRQ as output\n",
                          __func__);
-@@ -2818,7 +2820,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
+@@ -2820,7 +2822,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
                        set_bit(FLAG_IS_OUT, &desc->flags);
        }
  
index a42c894549aff195e9e2a164f3aac0afd69045a3..49156a0ada91cd47eddff5224e0e93e34c0ce466 100644 (file)
@@ -89,7 +89,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -1938,7 +1938,8 @@ int gpiochip_add_pingroup_range(struct g
+@@ -1940,7 +1940,8 @@ int gpiochip_add_pingroup_range(struct g
  
        list_add_tail(&pin_range->node, &gdev->pin_ranges);
  
@@ -99,7 +99,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  }
  EXPORT_SYMBOL_GPL(gpiochip_add_pingroup_range);
  
-@@ -1990,7 +1991,7 @@ int gpiochip_add_pin_range(struct gpio_c
+@@ -1992,7 +1993,7 @@ int gpiochip_add_pin_range(struct gpio_c
  
        list_add_tail(&pin_range->node, &gdev->pin_ranges);
  
index 3df01c34b10207865f678f7e327f438160628fa9..1c82a9576aad47704664559d52f63c2f1ae49969 100644 (file)
@@ -10,9 +10,9 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -428,8 +428,8 @@ KBUILD_CFLAGS_MODULE  := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+@@ -429,8 +429,8 @@ KBUILD_LDFLAGS_MODULE := -T $(srctree)/s
  GCC_PLUGINS_CFLAGS :=
+ CLANG_FLAGS :=
  
 -export ARCH SRCARCH CONFIG_SHELL HOSTCC HOSTCFLAGS CROSS_COMPILE AS LD CC
 -export CPP AR NM STRIP OBJCOPY OBJDUMP HOSTLDFLAGS HOST_LOADLIBES
index b45a8e3bc2c115a45df56ae5637502fccbd58689..16b10e76b8f3e90e565361b60fa7af9856c90780 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1240,7 +1240,6 @@ all: modules
+@@ -1241,7 +1241,6 @@ all: modules
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
  
-@@ -1269,7 +1268,6 @@ _modinst_:
+@@ -1270,7 +1269,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi
index d257232403995fa5c838478f139f7201fd1d346b..7d791eb4513d271f2dfbe9ce78691a6bb4ed3799 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)
  KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
  KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -788,11 +793,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
+@@ -789,11 +794,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
  KBUILD_CFLAGS += $(call cc-option, -fno-inline-functions-called-once)
  endif
  
index 6f4e465f652137d5023bc04bf31501fef6c86d24..305ba3aad228ce5d87f0677575c2f227d08877ce 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -655,12 +655,12 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
+@@ -656,12 +656,12 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
  KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE