mvebu: refresh patches
authorFlorian Fainelli <florian@openwrt.org>
Thu, 17 Jan 2013 22:28:58 +0000 (22:28 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 17 Jan 2013 22:28:58 +0000 (22:28 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 35210

21 files changed:
target/linux/mvebu/patches-3.8/004-net_mvneta_fix_driver_operations_smp.patch
target/linux/mvebu/patches-3.8/005-arm_mvebu_use_global_interrupts_for_gpio.patch
target/linux/mvebu/patches-3.8/006-mmc_mvsdio_use_slot_gpio.patch
target/linux/mvebu/patches-3.8/007-mmc_mvsdio_use_slot_gpio_for_cd.patch
target/linux/mvebu/patches-3.8/008-mmc_mvsdio_implement_a_device_tree_binding.patch
target/linux/mvebu/patches-3.8/009-mmc_mvsdio_add_pinctrl.patch
target/linux/mvebu/patches-3.8/010-arm_mvebu_add_dt_info_a370.patch
target/linux/mvebu/patches-3.8/011-arm_mvebu_add_pin_mux_options_a370.patch
target/linux/mvebu/patches-3.8/012-arm_mvebu_add_pin_mux_options_axp.patch
target/linux/mvebu/patches-3.8/013-arm_mvebu_enable_sd_cart_slot_axp_db.patch
target/linux/mvebu/patches-3.8/014-arm_mvebu_enable_sd_card_slot_a370_db.patch
target/linux/mvebu/patches-3.8/015-arm_mvebu_enable_sd_card_slot_mirabox.patch
target/linux/mvebu/patches-3.8/019-rtc_add_support_for_rtc_mv_for_mvebu.patch
target/linux/mvebu/patches-3.8/020-arm_mvebu_add_rtc_support_for_a370_and_axp.patch
target/linux/mvebu/patches-3.8/021-arm_mvebu_add_rd_a370_a1_dts.patch
target/linux/mvebu/patches-3.8/022-arm_mvebu_enable_sd_card_slot_a370_rd.patch
target/linux/mvebu/patches-3.8/023-arm_mvebu_add_support_for_usb_host.patch
target/linux/mvebu/patches-3.8/024-arm_mvebu_enable_usb_a370.patch
target/linux/mvebu/patches-3.8/025-arm_mvebu_enable_usb_a370_mirabox.patch
target/linux/mvebu/patches-3.8/026-arm_mvebu_enale_usb_axp.patch
target/linux/mvebu/patches-3.8/027-arm_mvebu_enable_axp_openblocks.patch

index c7e992fc4f690e7eab1cc606cfc3ea0e2b6a6729..d1a8e42b98ac6a574fa4abb07705519e0aa0dd35 100644 (file)
@@ -22,11 +22,9 @@ This is 3.8-rc material.
  drivers/net/ethernet/marvell/mvneta.c |   17 +++++++++++++++--
  1 file changed, 15 insertions(+), 2 deletions(-)
 
-diff --git a/drivers/net/ethernet/marvell/mvneta.c b/drivers/net/ethernet/marvell/mvneta.c
-index b6025c3..af2c421 100644
 --- a/drivers/net/ethernet/marvell/mvneta.c
 +++ b/drivers/net/ethernet/marvell/mvneta.c
-@@ -1310,6 +1310,17 @@ static u32 mvneta_skb_tx_csum(struct mvneta_port *pp, struct sk_buff *skb)
+@@ -1310,6 +1310,17 @@ static u32 mvneta_skb_tx_csum(struct mvn
        return MVNETA_TX_L4_CSUM_NOT;
  }
  
@@ -54,7 +52,7 @@ index b6025c3..af2c421 100644
        struct mvneta_tx_desc *tx_desc;
        struct netdev_queue *nq;
        int frags = 0;
-@@ -1486,7 +1498,7 @@ static int mvneta_tx(struct sk_buff *skb, struct net_device *dev)
+@@ -1486,7 +1498,7 @@ static int mvneta_tx(struct sk_buff *skb
                goto out;
  
        frags = skb_shinfo(skb)->nr_frags + 1;
@@ -63,7 +61,7 @@ index b6025c3..af2c421 100644
  
        /* Get a descriptor for the first part of the packet */
        tx_desc = mvneta_txq_next_desc_get(txq);
-@@ -2550,6 +2562,7 @@ static const struct net_device_ops mvneta_netdev_ops = {
+@@ -2550,6 +2562,7 @@ static const struct net_device_ops mvnet
        .ndo_change_mtu      = mvneta_change_mtu,
        .ndo_tx_timeout      = mvneta_tx_timeout,
        .ndo_get_stats64     = mvneta_get_stats64,
@@ -71,5 +69,3 @@ index b6025c3..af2c421 100644
  };
  
  const struct ethtool_ops mvneta_eth_tool_ops = {
--- 
-1.7.9.5
index 726e2529fc5970de28cd031722d89a3cfee0b937..e190a3301fbc6b1bf803f7e919af881013bca053 100644 (file)
@@ -26,8 +26,6 @@ This is 3.8-rc material.
  arch/arm/boot/dts/armada-xp-mv78460.dtsi |   21 +++++++++------------
  3 files changed, 24 insertions(+), 32 deletions(-)
 
-diff --git a/arch/arm/boot/dts/armada-xp-mv78230.dtsi b/arch/arm/boot/dts/armada-xp-mv78230.dtsi
-index 271855a..e041f42 100644
 --- a/arch/arm/boot/dts/armada-xp-mv78230.dtsi
 +++ b/arch/arm/boot/dts/armada-xp-mv78230.dtsi
 @@ -50,27 +50,25 @@
@@ -64,8 +62,6 @@ index 271855a..e041f42 100644
                };
        };
  };
-diff --git a/arch/arm/boot/dts/armada-xp-mv78260.dtsi b/arch/arm/boot/dts/armada-xp-mv78260.dtsi
-index 1c1937d..9e23bd8 100644
 --- a/arch/arm/boot/dts/armada-xp-mv78260.dtsi
 +++ b/arch/arm/boot/dts/armada-xp-mv78260.dtsi
 @@ -51,39 +51,36 @@
@@ -117,8 +113,6 @@ index 1c1937d..9e23bd8 100644
                };
  
                ethernet@d0034000 {
-diff --git a/arch/arm/boot/dts/armada-xp-mv78460.dtsi b/arch/arm/boot/dts/armada-xp-mv78460.dtsi
-index 4905cf3..9659661 100644
 --- a/arch/arm/boot/dts/armada-xp-mv78460.dtsi
 +++ b/arch/arm/boot/dts/armada-xp-mv78460.dtsi
 @@ -66,39 +66,36 @@
@@ -170,5 +164,3 @@ index 4905cf3..9659661 100644
                };
  
                ethernet@d0034000 {
--- 
-1.7.9.5
index 8a77de3068a21d77595eb78e1777295a58f51e53..35a2d8e5282f32e58485f02fb9c5aebd00f7d946 100644 (file)
@@ -10,8 +10,6 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  drivers/mmc/host/mvsdio.c |   34 +++++-----------------------------
  1 file changed, 5 insertions(+), 29 deletions(-)
 
-diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
-index de4c20b..a24a22f 100644
 --- a/drivers/mmc/host/mvsdio.c
 +++ b/drivers/mmc/host/mvsdio.c
 @@ -22,6 +22,7 @@
@@ -30,7 +28,7 @@ index de4c20b..a24a22f 100644
  };
  
  #define mvsd_write(offs, val) writel(val, iobase + (offs))
-@@ -566,20 +566,6 @@ static void mvsd_enable_sdio_irq(struct mmc_host *mmc, int enable)
+@@ -566,20 +566,6 @@ static void mvsd_enable_sdio_irq(struct
        spin_unlock_irqrestore(&host->lock, flags);
  }
  
@@ -51,7 +49,7 @@ index de4c20b..a24a22f 100644
  static void mvsd_power_up(struct mvsd_host *host)
  {
        void __iomem *iobase = host->base;
-@@ -676,7 +662,7 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
+@@ -676,7 +662,7 @@ static void mvsd_set_ios(struct mmc_host
  
  static const struct mmc_host_ops mvsd_ops = {
        .request                = mvsd_request,
@@ -60,7 +58,7 @@ index de4c20b..a24a22f 100644
        .set_ios                = mvsd_set_ios,
        .enable_sdio_irq        = mvsd_enable_sdio_irq,
  };
-@@ -798,15 +784,7 @@ static int __init mvsd_probe(struct platform_device *pdev)
+@@ -798,15 +784,7 @@ static int __init mvsd_probe(struct plat
        if (!host->gpio_card_detect)
                mmc->caps |= MMC_CAP_NEEDS_POLL;
  
@@ -87,7 +85,7 @@ index de4c20b..a24a22f 100644
                if (host->base)
                        iounmap(host->base);
        }
-@@ -861,8 +838,7 @@ static int __exit mvsd_remove(struct platform_device *pdev)
+@@ -861,8 +838,7 @@ static int __exit mvsd_remove(struct pla
                }
                mmc_remove_host(mmc);
                free_irq(host->irq, host);
@@ -97,5 +95,3 @@ index de4c20b..a24a22f 100644
                del_timer_sync(&host->timer);
                mvsd_power_down(host);
                iounmap(host->base);
--- 
-1.7.9.5
index 287dedf1d9ee7be2fce851c6788cbd754fac069e..bede3bf7e3601ea3f6a583b71c8536d96bf17ca1 100644 (file)
@@ -10,8 +10,6 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  drivers/mmc/host/mvsdio.c |   44 +++++++++-----------------------------------
  1 file changed, 9 insertions(+), 35 deletions(-)
 
-diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
-index a24a22f..baf19fc 100644
 --- a/drivers/mmc/host/mvsdio.c
 +++ b/drivers/mmc/host/mvsdio.c
 @@ -54,7 +54,6 @@ struct mvsd_host {
@@ -22,7 +20,7 @@ index a24a22f..baf19fc 100644
  };
  
  #define mvsd_write(offs, val) writel(val, iobase + (offs))
-@@ -540,13 +539,6 @@ static void mvsd_timeout_timer(unsigned long data)
+@@ -540,13 +539,6 @@ static void mvsd_timeout_timer(unsigned
                mmc_request_done(host->mmc, mrq);
  }
  
@@ -36,7 +34,7 @@ index a24a22f..baf19fc 100644
  static void mvsd_enable_sdio_irq(struct mmc_host *mmc, int enable)
  {
        struct mvsd_host *host = mmc_priv(mmc);
-@@ -765,23 +757,11 @@ static int __init mvsd_probe(struct platform_device *pdev)
+@@ -765,23 +757,11 @@ static int __init mvsd_probe(struct plat
                clk_prepare_enable(host->clk);
        }
  
@@ -65,7 +63,7 @@ index a24a22f..baf19fc 100644
                mmc->caps |= MMC_CAP_NEEDS_POLL;
  
        mmc_gpio_request_ro(mmc, mvsd_data->gpio_write_protect);
-@@ -794,9 +774,9 @@ static int __init mvsd_probe(struct platform_device *pdev)
+@@ -794,9 +774,9 @@ static int __init mvsd_probe(struct plat
  
        pr_notice("%s: %s driver initialized, ",
                           mmc_hostname(mmc), DRIVER_NAME);
@@ -89,7 +87,7 @@ index a24a22f..baf19fc 100644
                mmc_gpio_free_ro(mmc);
                if (host->base)
                        iounmap(host->base);
-@@ -832,10 +809,7 @@ static int __exit mvsd_remove(struct platform_device *pdev)
+@@ -832,10 +809,7 @@ static int __exit mvsd_remove(struct pla
        if (mmc) {
                struct mvsd_host *host = mmc_priv(mmc);
  
@@ -101,5 +99,3 @@ index a24a22f..baf19fc 100644
                mmc_remove_host(mmc);
                free_irq(host->irq, host);
                mmc_gpio_free_ro(mmc);
--- 
-1.7.9.5
index 4f8cc2011f40c4ea0f0fe60d40e8d9b79e6fe69c..7aa7856675fb3633e850d299f6ccb8a31eba2393 100644 (file)
@@ -17,9 +17,6 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  2 files changed, 62 insertions(+), 15 deletions(-)
  create mode 100644 Documentation/devicetree/bindings/mmc/orion-sdio.txt
 
-diff --git a/Documentation/devicetree/bindings/mmc/orion-sdio.txt b/Documentation/devicetree/bindings/mmc/orion-sdio.txt
-new file mode 100644
-index 0000000..84f0ebd
 --- /dev/null
 +++ b/Documentation/devicetree/bindings/mmc/orion-sdio.txt
 @@ -0,0 +1,17 @@
@@ -40,8 +37,6 @@ index 0000000..84f0ebd
 +              clocks = <&gateclk 17>;
 +              status = "disabled";
 +      };
-diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
-index baf19fc..56954bc 100644
 --- a/drivers/mmc/host/mvsdio.c
 +++ b/drivers/mmc/host/mvsdio.c
 @@ -21,6 +21,8 @@
@@ -53,7 +48,7 @@ index baf19fc..56954bc 100644
  #include <linux/mmc/host.h>
  #include <linux/mmc/slot-gpio.h>
  
-@@ -683,17 +685,17 @@ mv_conf_mbus_windows(struct mvsd_host *host,
+@@ -683,17 +685,17 @@ mv_conf_mbus_windows(struct mvsd_host *h
  
  static int __init mvsd_probe(struct platform_device *pdev)
  {
@@ -74,7 +69,7 @@ index baf19fc..56954bc 100644
                return -ENXIO;
  
        r = request_mem_region(r->start, SZ_1K, DRIVER_NAME);
-@@ -710,7 +712,35 @@ static int __init mvsd_probe(struct platform_device *pdev)
+@@ -710,7 +712,35 @@ static int __init mvsd_probe(struct plat
        host->mmc = mmc;
        host->dev = &pdev->dev;
        host->res = r;
@@ -111,7 +106,7 @@ index baf19fc..56954bc 100644
  
        mmc->ops = &mvsd_ops;
  
-@@ -750,21 +780,14 @@ static int __init mvsd_probe(struct platform_device *pdev)
+@@ -750,21 +780,14 @@ static int __init mvsd_probe(struct plat
        } else
                host->irq = irq;
  
@@ -136,7 +131,7 @@ index baf19fc..56954bc 100644
  
        setup_timer(&host->timer, mvsd_timeout_timer, (unsigned long)host);
        platform_set_drvdata(pdev, mmc);
-@@ -776,7 +799,7 @@ static int __init mvsd_probe(struct platform_device *pdev)
+@@ -776,7 +799,7 @@ static int __init mvsd_probe(struct plat
                           mmc_hostname(mmc), DRIVER_NAME);
        if (!(mmc->caps & MMC_CAP_NEEDS_POLL))
                printk("using GPIO %d for card detection\n",
@@ -145,7 +140,7 @@ index baf19fc..56954bc 100644
        else
                printk("lacking card detect (fall back to polling)\n");
        return 0;
-@@ -855,12 +878,19 @@ static int mvsd_resume(struct platform_device *dev)
+@@ -855,12 +878,19 @@ static int mvsd_resume(struct platform_d
  #define mvsd_resume   NULL
  #endif
  
@@ -165,5 +160,3 @@ index baf19fc..56954bc 100644
        },
  };
  
--- 
-1.7.9.5
index 394fc4cebabd307f128c1a697680c72be0635ee5..9f98bda135816e72f11f47eb772f3e3b6ca170ad 100644 (file)
@@ -13,8 +13,6 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  drivers/mmc/host/mvsdio.c |    6 ++++++
  1 file changed, 6 insertions(+)
 
-diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
-index 56954bc..feb16bd 100644
 --- a/drivers/mmc/host/mvsdio.c
 +++ b/drivers/mmc/host/mvsdio.c
 @@ -25,6 +25,7 @@
@@ -25,7 +23,7 @@ index 56954bc..feb16bd 100644
  
  #include <asm/sizes.h>
  #include <asm/unaligned.h>
-@@ -692,6 +693,7 @@ static int __init mvsd_probe(struct platform_device *pdev)
+@@ -692,6 +693,7 @@ static int __init mvsd_probe(struct plat
        struct resource *r;
        int ret, irq;
        int gpio_card_detect, gpio_write_protect;
@@ -33,7 +31,7 @@ index 56954bc..feb16bd 100644
  
        r = platform_get_resource(pdev, IORESOURCE_MEM, 0);
        irq = platform_get_irq(pdev, 0);
-@@ -713,6 +715,10 @@ static int __init mvsd_probe(struct platform_device *pdev)
+@@ -713,6 +715,10 @@ static int __init mvsd_probe(struct plat
        host->dev = &pdev->dev;
        host->res = r;
  
@@ -44,5 +42,3 @@ index 56954bc..feb16bd 100644
        /* Some non-DT platforms do not pass a clock, and the clock
           frequency is passed through platform_data. On DT platforms,
           a clock must always be passed, even if there is no gatable
--- 
-1.7.9.5
index 36e5ea2a228175f53d1d1bb059de079deabfbdf2..bf4d9d4f5ff3b8d725f1693b92ea3f64c136f3c9 100644 (file)
@@ -7,11 +7,9 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  arch/arm/boot/dts/armada-370-xp.dtsi |    8 ++++++++
  1 file changed, 8 insertions(+)
 
-diff --git a/arch/arm/boot/dts/armada-370-xp.dtsi b/arch/arm/boot/dts/armada-370-xp.dtsi
-index cf6c48a..41a5b11 100644
 --- a/arch/arm/boot/dts/armada-370-xp.dtsi
 +++ b/arch/arm/boot/dts/armada-370-xp.dtsi
-@@ -129,6 +129,14 @@
+@@ -131,6 +131,14 @@
                        clocks = <&coreclk 0>;
                        status = "disabled";
                };
@@ -26,5 +24,3 @@ index cf6c48a..41a5b11 100644
        };
  };
  
--- 
-1.7.9.5
index 6b245a0179790fc38a4f33126d069efddfd8acc4..4072ae50cd2318d0d05e52f6d25d67abca4e6e4a 100644 (file)
@@ -11,8 +11,6 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  arch/arm/boot/dts/armada-370.dtsi |   12 ++++++++++++
  1 file changed, 12 insertions(+)
 
-diff --git a/arch/arm/boot/dts/armada-370.dtsi b/arch/arm/boot/dts/armada-370.dtsi
-index 636cf7d..88f9bab 100644
 --- a/arch/arm/boot/dts/armada-370.dtsi
 +++ b/arch/arm/boot/dts/armada-370.dtsi
 @@ -47,6 +47,18 @@
@@ -34,5 +32,3 @@ index 636cf7d..88f9bab 100644
                };
  
                gpio0: gpio@d0018100 {
--- 
-1.7.9.5
index f4d9a96f8382d3c93c282793a1a9c92c5e6dbe94..716971dff4ff62fa4a08213aeb6baf041fd6aebe 100644 (file)
@@ -14,11 +14,9 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  arch/arm/boot/dts/armada-xp-mv78460.dtsi |    6 ++++++
  3 files changed, 18 insertions(+)
 
-diff --git a/arch/arm/boot/dts/armada-xp-mv78230.dtsi b/arch/arm/boot/dts/armada-xp-mv78230.dtsi
-index c45c7b4..3fa9c84 100644
 --- a/arch/arm/boot/dts/armada-xp-mv78230.dtsi
 +++ b/arch/arm/boot/dts/armada-xp-mv78230.dtsi
-@@ -40,6 +40,12 @@
+@@ -47,6 +47,12 @@
                pinctrl {
                        compatible = "marvell,mv78230-pinctrl";
                        reg = <0xd0018000 0x38>;
@@ -31,8 +29,6 @@ index c45c7b4..3fa9c84 100644
                };
  
                gpio0: gpio@d0018100 {
-diff --git a/arch/arm/boot/dts/armada-xp-mv78260.dtsi b/arch/arm/boot/dts/armada-xp-mv78260.dtsi
-index a2aee57..5a907b3 100644
 --- a/arch/arm/boot/dts/armada-xp-mv78260.dtsi
 +++ b/arch/arm/boot/dts/armada-xp-mv78260.dtsi
 @@ -48,6 +48,12 @@
@@ -48,8 +44,6 @@ index a2aee57..5a907b3 100644
                };
  
                gpio0: gpio@d0018100 {
-diff --git a/arch/arm/boot/dts/armada-xp-mv78460.dtsi b/arch/arm/boot/dts/armada-xp-mv78460.dtsi
-index da03a12..6dcdc50d 100644
 --- a/arch/arm/boot/dts/armada-xp-mv78460.dtsi
 +++ b/arch/arm/boot/dts/armada-xp-mv78460.dtsi
 @@ -63,6 +63,12 @@
@@ -65,5 +59,3 @@ index da03a12..6dcdc50d 100644
                };
  
                gpio0: gpio@d0018100 {
--- 
-1.7.9.5
index f013ec0f115916eb675a9174124f3b5f0fd73a64..5a6faf9d973b38fe652dadc5a08b83207262fbfb 100644 (file)
@@ -8,8 +8,6 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  arch/arm/boot/dts/armada-xp-db.dts |    7 +++++++
  1 file changed, 7 insertions(+)
 
-diff --git a/arch/arm/boot/dts/armada-xp-db.dts b/arch/arm/boot/dts/armada-xp-db.dts
-index 8e53b25..c7035c5 100644
 --- a/arch/arm/boot/dts/armada-xp-db.dts
 +++ b/arch/arm/boot/dts/armada-xp-db.dts
 @@ -90,5 +90,12 @@
@@ -25,5 +23,3 @@ index 8e53b25..c7035c5 100644
 +              };
        };
  };
--- 
-1.7.9.5
index 456c281d8a2e76e2621fc4437224dba6c2227cd8..d9214163c28805502ae957fdca84e8fb481f2e8d 100644 (file)
@@ -16,8 +16,6 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  arch/arm/boot/dts/armada-370-db.dts |   15 +++++++++++++++
  1 file changed, 15 insertions(+)
 
-diff --git a/arch/arm/boot/dts/armada-370-db.dts b/arch/arm/boot/dts/armada-370-db.dts
-index 0004402..43ff156 100644
 --- a/arch/arm/boot/dts/armada-370-db.dts
 +++ b/arch/arm/boot/dts/armada-370-db.dts
 @@ -59,5 +59,20 @@
@@ -41,5 +39,3 @@ index 0004402..43ff156 100644
 +              };
        };
  };
--- 
-1.7.9.5
index 3868d46d8d76992945148264c3c4dec8b0ad84c7..0cf6ee4101c12acfefb3d64eeaad3ccb1d0ab768 100644 (file)
@@ -7,8 +7,6 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  arch/arm/boot/dts/armada-370-mirabox.dts |   10 ++++++++++
  1 file changed, 10 insertions(+)
 
-diff --git a/arch/arm/boot/dts/armada-370-mirabox.dts b/arch/arm/boot/dts/armada-370-mirabox.dts
-index 3b40713..1864820 100644
 --- a/arch/arm/boot/dts/armada-370-mirabox.dts
 +++ b/arch/arm/boot/dts/armada-370-mirabox.dts
 @@ -52,5 +52,15 @@
@@ -27,5 +25,3 @@ index 3b40713..1864820 100644
 +              };
        };
  };
--- 
-1.7.9.5
index 0142f251f4a194adbb19f91c412e8554b1c6647e..373058ae59be82446c49d8e7b1e85f855b80a731 100644 (file)
@@ -8,11 +8,9 @@ Acked-by: Andrew Lunn <andrew@lunn.ch>
  drivers/rtc/Kconfig |    2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/drivers/rtc/Kconfig b/drivers/rtc/Kconfig
-index 19c03ab..9356f75 100644
 --- a/drivers/rtc/Kconfig
 +++ b/drivers/rtc/Kconfig
-@@ -994,7 +994,7 @@ config RTC_DRV_TX4939
+@@ -1041,7 +1041,7 @@ config RTC_DRV_TX4939
  
  config RTC_DRV_MV
        tristate "Marvell SoC RTC"
@@ -21,5 +19,3 @@ index 19c03ab..9356f75 100644
        help
          If you say yes here you will get support for the in-chip RTC
          that can be found in some of Marvell's SoC devices, such as
--- 
-1.7.9.5
index c517b422263678af45b5c914d0fb6f0e2f70776f..307e8154655fefc0b6a912f5b34f890df61d7c4f 100644 (file)
@@ -8,12 +8,10 @@ Acked-by: Andrew Lunn <andrew@lunn.ch>
  arch/arm/boot/dts/armada-370-xp.dtsi |    6 ++++++
  1 file changed, 6 insertions(+)
 
-diff --git a/arch/arm/boot/dts/armada-370-xp.dtsi b/arch/arm/boot/dts/armada-370-xp.dtsi
-index cf6c48a..86dccfa 100644
 --- a/arch/arm/boot/dts/armada-370-xp.dtsi
 +++ b/arch/arm/boot/dts/armada-370-xp.dtsi
-@@ -129,6 +129,12 @@
-                       clocks = <&coreclk 0>;
+@@ -139,6 +139,12 @@
+                       clocks = <&gateclk 17>;
                        status = "disabled";
                };
 +
@@ -25,5 +23,3 @@ index cf6c48a..86dccfa 100644
        };
  };
  
--- 
-1.7.9.5
index 33033522e9a55e8b7851c125b7741454cef1bd40..6f52500e3b2123c13090b3a94548e375c0f5a57d 100644 (file)
@@ -15,11 +15,9 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
  2 files changed, 62 insertions(+)
  create mode 100644 arch/arm/boot/dts/armada-370-rd.dts
 
-diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index b7246d6..7a75171 100644
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -78,6 +78,7 @@ dtb-$(CONFIG_ARCH_MSM) += msm8660-surf.dtb \
+@@ -77,6 +77,7 @@ dtb-$(CONFIG_ARCH_MSM) += msm8660-surf.d
        msm8960-cdp.dtb
  dtb-$(CONFIG_ARCH_MVEBU) += armada-370-db.dtb \
        armada-370-mirabox.dtb \
@@ -27,9 +25,6 @@ index b7246d6..7a75171 100644
        armada-xp-db.dtb \
        armada-xp-openblocks-ax3-4.dtb
  dtb-$(CONFIG_ARCH_MXC) += imx51-babbage.dtb \
-diff --git a/arch/arm/boot/dts/armada-370-rd.dts b/arch/arm/boot/dts/armada-370-rd.dts
-new file mode 100644
-index 0000000..d62dfac
 --- /dev/null
 +++ b/arch/arm/boot/dts/armada-370-rd.dts
 @@ -0,0 +1,61 @@
@@ -94,6 +89,3 @@ index 0000000..d62dfac
 +              };
 +      };
 +};
--- 
-1.7.10.4
-
index 0f7f808ab6bb633ca9c10d326170b923a785c701..439711aae0233ff0cd362f2d9aa54aa11c8b0147 100644 (file)
@@ -11,8 +11,6 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
  arch/arm/boot/dts/armada-370-rd.dts |    6 ++++++
  1 file changed, 6 insertions(+)
 
-diff --git a/arch/arm/boot/dts/armada-370-rd.dts b/arch/arm/boot/dts/armada-370-rd.dts
-index d62dfac..43f68c2 100644
 --- a/arch/arm/boot/dts/armada-370-rd.dts
 +++ b/arch/arm/boot/dts/armada-370-rd.dts
 @@ -57,5 +57,11 @@
@@ -27,6 +25,3 @@ index d62dfac..43f68c2 100644
 +              };
        };
  };
--- 
-1.7.10.4
-
index 63aff01ae1ab6f1e340c9ebcff3048b811a148e4..1484c08ee56a9e65b0fae233b81d8c67ed7e131e 100644 (file)
@@ -13,13 +13,11 @@ Signed-off-by: Ezequiel Garcia <ezequiel.garcia@free-electrons.com>
  arch/arm/mach-mvebu/Kconfig          |    1 +
  4 files changed, 42 insertions(+), 0 deletions(-)
 
-diff --git a/arch/arm/boot/dts/armada-370-xp.dtsi b/arch/arm/boot/dts/armada-370-xp.dtsi
-index 28276fe..fa025c4 100644
 --- a/arch/arm/boot/dts/armada-370-xp.dtsi
 +++ b/arch/arm/boot/dts/armada-370-xp.dtsi
 @@ -145,6 +145,21 @@
-                       clocks = <&gateclk 17>;
-                       status = "disabled";
+                       reg = <0xd0010300 0x20>;
+                       interrupts = <50>;
                };
 +
 +              usb@d0050000 {
@@ -39,8 +37,6 @@ index 28276fe..fa025c4 100644
        };
  };
  
-diff --git a/arch/arm/boot/dts/armada-370.dtsi b/arch/arm/boot/dts/armada-370.dtsi
-index 88f9bab..8188d13 100644
 --- a/arch/arm/boot/dts/armada-370.dtsi
 +++ b/arch/arm/boot/dts/armada-370.dtsi
 @@ -144,5 +144,14 @@
@@ -58,8 +54,6 @@ index 88f9bab..8188d13 100644
 +
        };
  };
-diff --git a/arch/arm/boot/dts/armada-xp.dtsi b/arch/arm/boot/dts/armada-xp.dtsi
-index 390ba98..1443949 100644
 --- a/arch/arm/boot/dts/armada-xp.dtsi
 +++ b/arch/arm/boot/dts/armada-xp.dtsi
 @@ -134,5 +134,22 @@
@@ -85,8 +79,6 @@ index 390ba98..1443949 100644
 +
        };
  };
-diff --git a/arch/arm/mach-mvebu/Kconfig b/arch/arm/mach-mvebu/Kconfig
-index 440b13e..5e4fcde 100644
 --- a/arch/arm/mach-mvebu/Kconfig
 +++ b/arch/arm/mach-mvebu/Kconfig
 @@ -24,6 +24,7 @@ config MACH_ARMADA_370_XP
@@ -97,5 +89,3 @@ index 440b13e..5e4fcde 100644
  
  config MACH_ARMADA_370
        bool "Marvell Armada 370 boards"
--- 
-1.7.8.6
index 46b554b17ad243d44691998d1bd6939bc8c8c897..1a20a144b4bbf7336cf9b2cbbb68f6839db74ecc 100644 (file)
@@ -6,8 +6,6 @@ Signed-off-by: Ezequiel Garcia <ezequiel.garcia@free-electrons.com>
  arch/arm/boot/dts/armada-370-db.dts |    8 ++++++++
  1 files changed, 8 insertions(+), 0 deletions(-)
 
-diff --git a/arch/arm/boot/dts/armada-370-db.dts b/arch/arm/boot/dts/armada-370-db.dts
-index 8e66a7c..3d93902 100644
 --- a/arch/arm/boot/dts/armada-370-db.dts
 +++ b/arch/arm/boot/dts/armada-370-db.dts
 @@ -74,5 +74,13 @@
@@ -24,7 +22,3 @@ index 8e66a7c..3d93902 100644
 +              };
        };
  };
--- 
-1.7.8.6
-
-
index 88b20c3abbbe77c8d91bd03c51ea5b6cfd103670..82d059eb7c1f9f6b2d004cdb4618a942bde090ca 100644 (file)
@@ -6,8 +6,6 @@ Signed-off-by: Ezequiel Garcia <ezequiel.garcia@free-electrons.com>
  arch/arm/boot/dts/armada-370-mirabox.dts |    8 ++++++++
  1 files changed, 8 insertions(+), 0 deletions(-)
 
-diff --git a/arch/arm/boot/dts/armada-370-mirabox.dts b/arch/arm/boot/dts/armada-370-mirabox.dts
-index 1864820..dd0c57d 100644
 --- a/arch/arm/boot/dts/armada-370-mirabox.dts
 +++ b/arch/arm/boot/dts/armada-370-mirabox.dts
 @@ -62,5 +62,13 @@
@@ -24,5 +22,3 @@ index 1864820..dd0c57d 100644
 +              };
        };
  };
--- 
-1.7.8.6
index 8f44072de5afe173ad6016c642716d053eb9d149..f3851b03943ed2fe8b3250f9a78553e2d69789f8 100644 (file)
@@ -6,8 +6,6 @@ Signed-off-by: Ezequiel Garcia <ezequiel.garcia@free-electrons.com>
  arch/arm/boot/dts/armada-xp-db.dts |   12 ++++++++++++
  1 files changed, 12 insertions(+), 0 deletions(-)
 
-diff --git a/arch/arm/boot/dts/armada-xp-db.dts b/arch/arm/boot/dts/armada-xp-db.dts
-index c7035c5..c84e1fe 100644
 --- a/arch/arm/boot/dts/armada-xp-db.dts
 +++ b/arch/arm/boot/dts/armada-xp-db.dts
 @@ -97,5 +97,17 @@
@@ -28,5 +26,3 @@ index c7035c5..c84e1fe 100644
 +              };
        };
  };
--- 
-1.7.8.6
index d9f64489761cfbb584349655b5ce95137ad4474f..2078260d61a5f02e9dea776084842cfb78e8f3d6 100644 (file)
@@ -6,11 +6,9 @@ Signed-off-by: Ezequiel Garcia <ezequiel.garcia@free-electrons.com>
  arch/arm/boot/dts/armada-xp-openblocks-ax3-4.dts |    9 +++++++++
  1 files changed, 9 insertions(+), 0 deletions(-)
 
-diff --git a/arch/arm/boot/dts/armada-xp-openblocks-ax3-4.dts b/arch/arm/boot/dts/armada-xp-openblocks-ax3-4.dts
-index b24644f..55f5b6f 100644
 --- a/arch/arm/boot/dts/armada-xp-openblocks-ax3-4.dts
 +++ b/arch/arm/boot/dts/armada-xp-openblocks-ax3-4.dts
-@@ -127,5 +127,14 @@
+@@ -121,5 +121,14 @@
                        nr-ports = <2>;
                        status = "okay";
                };
@@ -25,7 +23,3 @@ index b24644f..55f5b6f 100644
 +              };
        };
  };
--- 
-1.7.8.6
-
-