dropbear: rebuild libs on config change
authorYousong Zhou <yszhou4tech@gmail.com>
Fri, 1 Nov 2019 06:57:03 +0000 (06:57 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Fri, 1 Nov 2019 06:59:51 +0000 (06:59 +0000)
Required as dependency on dropbear config headers is not tracked in
dropbear build system

Fixes FS#2275

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
package/network/services/dropbear/Makefile

index 63204042f71a250f257ed5cdfb98bffb66a56bd7..75a3264ebbe79a8b5a399a146f670db52d694f9f 100644 (file)
@@ -128,6 +128,10 @@ define Build/Configure
 
        # Enforce rebuild of svr-chansession.c
        rm -f $(PKG_BUILD_DIR)/svr-chansession.o
+
+       # Rebuild them on config change
+       +$(MAKE) -C $(PKG_BUILD_DIR)/libtomcrypt clean
+       +$(MAKE) -C $(PKG_BUILD_DIR)/libtommath clean
 endef
 
 define Build/Compile