qualcommax: ipq807x: Create working factory tar for WAX620 and WAX630.
authorErik Servili <serverror@serverror.com>
Mon, 24 Mar 2025 22:12:54 +0000 (23:12 +0100)
committerRobert Marko <robimarko@gmail.com>
Wed, 26 Mar 2025 08:52:41 +0000 (09:52 +0100)
Create factory tar for WAX620 and WAX630 which is accepted by the stock UI.
Must use 'Boot up Backup Firmware' button on stock upgrade page after install and reboot to swap partitions.

Signed-off-by: Erik Servili <serverror@serverror.com>
Link: https://github.com/openwrt/openwrt/pull/18334
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/qualcommax/image/ipq807x.mk
target/linux/qualcommax/ipq807x/base-files/etc/init.d/bootcount

index 48dd7f7a39399c87e986ec7f16324086b9615b75..378f37501bf4c821807a81b146df3a618aaed4e3 100644 (file)
@@ -28,7 +28,7 @@ define Build/wax6xx-netgear-tar
        mv $@ $@.tmp/nand-ipq807x-apps.img
        md5sum $@.tmp/nand-ipq807x-apps.img | cut -c 1-32 > $@.tmp/nand-ipq807x-apps.md5sum
        echo $(DEVICE_MODEL) > $@.tmp/metadata.txt
-       echo $(DEVICE_MODEL)"_V9.9.9.9" > $@.tmp/version
+       echo $(DEVICE_MODEL)"_V99.9.9.9" > $@.tmp/version
        tar -C $@.tmp/ -cf $@ .
        rm -rf $@.tmp
 endef
@@ -326,6 +326,8 @@ define Device/netgear_wax620
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        SOC := ipq8072
+       IMAGES += ui-factory.tar
+       IMAGE/ui-factory.tar := append-ubi | qsdk-ipq-factory-nand | pad-to 4096 | wax6xx-netgear-tar
        DEVICE_PACKAGES := kmod-spi-gpio kmod-gpio-nxp-74hc164 \
                ipq-wifi-netgear_wax620
 endef
@@ -341,7 +343,7 @@ define Device/netgear_wax630
        PAGESIZE := 2048
        SOC := ipq8074
        IMAGES += ui-factory.tar
-       IMAGE/ui-factory.tar := append-ubi | wax6xx-netgear-tar
+       IMAGE/ui-factory.tar := append-ubi | qsdk-ipq-factory-nand | pad-to 4096 | wax6xx-netgear-tar
        DEVICE_PACKAGES := kmod-spi-gpio ipq-wifi-netgear_wax630
 endef
 TARGET_DEVICES += netgear_wax630
index 176a5a144a07993a8ad5a4bbd853c9e0bb26ba30..e7c20493b64c10f01228c36e9c3c89f5888749eb 100755 (executable)
@@ -17,5 +17,9 @@ boot() {
        linksys,mx8500)
                mtd resetbc s_env || true
        ;;
+       netgear,wax620|\
+       netgear,wax630)
+               fw_setenv boot_count 0
+       ;;
        esac
 }