kernel: bump 4.14 to 4.14.78
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 22 Oct 2018 12:13:40 +0000 (14:13 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 22 Oct 2018 13:29:01 +0000 (15:29 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/apm821xx/patches-4.14/030-0002-net-ibm-emac-replace-custom-PHY_MODE_-macros.patch
target/linux/apm821xx/patches-4.14/701-powerpc_ibm_apm82181_phyclk_fix.patch

index 487039e53bc62cb03f794b2c0797819550932414..f0ac2671ed134891339d560f88a67ea4cd69f23e 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .135
-LINUX_VERSION-4.14 = .77
+LINUX_VERSION-4.14 = .78
 
 LINUX_KERNEL_HASH-4.9.135 = e023b0bbe9ea7fc56aa57210342dd18ea3e0900ee207226df1523c6d7df154ce
-LINUX_KERNEL_HASH-4.14.77 = 0496f4e194cadbe23f27e6f4b9c3cd264448983780b73b30f7f05c92273fa6f8
+LINUX_KERNEL_HASH-4.14.78 = f4da4dc0f079e420e1c1b8c71312eaa5415b08be847aa224a61d8af6a6e74c6c
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index e4a722646e1c5575311177ab2c76a3aca8082044..ba4fb5f717506a3eafacacb533526a271e4604aa 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
  }
  
  static inline void emac_tx_enable(struct emac_instance *dev)
-@@ -2865,7 +2865,7 @@ static int emac_init_config(struct emac_
+@@ -2870,7 +2870,7 @@ static int emac_init_config(struct emac_
        /* PHY mode needs some decoding */
        dev->phy_mode = of_get_phy_mode(np);
        if (dev->phy_mode < 0)
@@ -56,7 +56,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
  
        /* Check EMAC version */
        if (of_device_is_compatible(np, "ibm,emac4sync")) {
-@@ -3168,7 +3168,7 @@ static int emac_probe(struct platform_de
+@@ -3173,7 +3173,7 @@ static int emac_probe(struct platform_de
        printk(KERN_INFO "%s: EMAC-%d %pOF, MAC %pM\n",
               ndev->name, dev->cell_index, np, ndev->dev_addr);
  
index 7f630a3c2a23cab2371d0e7a89db5f23d43a00cb..ced284ee3b2cd4b41e7f7e8ece016feeb3a6fbf4 100644 (file)
@@ -30,7 +30,7 @@
  #endif
  }
  
-@@ -2879,6 +2888,7 @@ static int emac_init_config(struct emac_
+@@ -2884,6 +2893,7 @@ static int emac_init_config(struct emac_
                if (of_device_is_compatible(np, "ibm,emac-apm821xx")) {
                        dev->features |= (EMAC_APM821XX_REQ_JUMBO_FRAME_SIZE |
                                          EMAC_FTR_APM821XX_NO_HALF_DUPLEX |