zynq: make title consistent for all devices
authorLuis Araneda <luaraneda@gmail.com>
Thu, 16 May 2019 03:57:19 +0000 (23:57 -0400)
committerPetr Štetiar <ynezz@true.cz>
Fri, 17 May 2019 19:41:43 +0000 (21:41 +0200)
Modify the title to match the following format, as it's enough
to uniquely identify a device:
<manufacturer> <model>

This matches what's done for other targets and has the
added benefit of creating a sorted-by-manufacturer list
of devices on menuconfig

Signed-off-by: Luis Araneda <luaraneda@gmail.com>
target/linux/zynq/image/Makefile

index d8a882313bab05677ca27d9d0ad369bebe06202e..6e45d2bca4e69f9991d01eb6699d740aba21a79d 100644 (file)
@@ -51,28 +51,28 @@ endef
 
 define Device/avnet_zynq-zed
        $(call Device/FitImageGzip)
-       DEVICE_TITLE := Avnet ZedBoard board
+       DEVICE_TITLE := Avnet ZedBoard
        DEVICE_DTS := zynq-zed
 endef
 TARGET_DEVICES += avnet_zynq-zed
 
 define Device/digilent_zynq-zybo
        $(call Device/FitImageGzip)
-       DEVICE_TITLE := ZYBO Development Board
+       DEVICE_TITLE := Digilent Zybo
        DEVICE_DTS := zynq-zybo
 endef
 TARGET_DEVICES += digilent_zynq-zybo
 
 define Device/digilent_zynq-zybo-z7
        $(call Device/FitImageGzip)
-       DEVICE_TITLE := Digilent Zybo Z7 board
+       DEVICE_TITLE := Digilent Zybo Z7
        DEVICE_DTS := zynq-zybo-z7
 endef
 TARGET_DEVICES += digilent_zynq-zybo-z7
 
 define Device/xlnx_zynq-zc702
        $(call Device/FitImageGzip)
-       DEVICE_TITLE := ZC702 Development Board
+       DEVICE_TITLE := Xilinx ZC702
        DEVICE_DTS := zynq-zc702
        DEVICE_PACKAGES:=kmod-can kmod-can-xilinx-can
 endef