Add menuconfig option for enabling profiling in the kernel.
authorLars-Peter Clausen <lars@metafoo.de>
Thu, 29 Jan 2009 23:52:35 +0000 (23:52 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Thu, 29 Jan 2009 23:52:35 +0000 (23:52 +0000)
SVN-Revision: 14272

Config.in
include/kernel-defaults.mk

index 0f131f062395f9f1c6355940987530cd614fd2b4..7c980445300b8832735c51ee59eeefc3aaff7e18 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -124,6 +124,12 @@ config KERNEL_KALLSYMS
        default n
        help
                This will give you more information in stack traces from kernel oopses
+config KERNEL_PROFILING
+       bool "Compile the kernel with profiling enabled"
+       default n
+       help
+               Enable the extended profiling support mechanisms used by profilers such
+               as OProfile.
 
 endmenu
 
index 4aa5c0ef18232305df8c7412e37dccbf08e9cea2..e3897a64cc4fd398084d1416f0e3b46a93e2dc3d 100644 (file)
@@ -87,6 +87,7 @@ endef
 define Kernel/Configure/Default
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config.target
        echo "$(if $(CONFIG_KERNEL_KALLSYMS),CONFIG_KALLSYMS=y,# CONFIG_KALLSYMS is not set)" >> $(LINUX_DIR)/.config.target
+       echo "$(if $(CONFIG_KERNEL_PROFILING),CONFIG_PROFILING=y,# CONFIG_PROFILING is not set)" >> $(LINUX_DIR)/.config.target
        echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
        echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
        $(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config > $(LINUX_DIR)/.config.override