brcm47xx: fix padding of trx images, padjffs2 does not work properly on empty files...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 29 Aug 2011 21:23:51 +0000 (21:23 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 29 Aug 2011 21:23:51 +0000 (21:23 +0000)
SVN-Revision: 28125

target/linux/brcm47xx/image/Makefile

index bc2ff3a8f122634c9aaa6a8be27c5be6669de7f9..f7cce169951f95393327be87b249100728084dea 100644 (file)
@@ -20,7 +20,7 @@ define Image/Prepare
                clean install
        echo -ne "\\x00" >> $(KDIR)/loader.gz
        rm -f $(KDIR)/fs_mark
-       touch $(KDIR)/fs_mark
+       echo -ne '\xde\xad\xc0\xde' > $(KDIR)/fs_mark
        $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
 endef