brcm63xx: Add DT support for CT-6373
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:14 +0000 (11:28 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:14 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
[jogo: make linux partition writable]
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42238

28 files changed:
target/linux/brcm63xx/dts/ct-6373.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/comtrend.mk

diff --git a/target/linux/brcm63xx/dts/ct-6373.dts b/target/linux/brcm63xx/dts/ct-6373.dts
new file mode 100644 (file)
index 0000000..1aca23a
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+       model = "Comtrend CT-6373";
+       compatible = "comtrend,ct-6373", "brcm,bcm6358";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x7e0000>;
+       };
+
+       nvram@7f0000 {
+               label = "nvram";
+               reg = <0x7f0000 0x010000>;
+       };
+};
index 487d6746b387f2de029dd10ba0dfc77f9d3f86b0..f3782ee941ee2ffd4131cede136e499cc46fc33b 100755 (executable)
@@ -271,8 +271,6 @@ define Image/Build
        # Sagem F@ST2504n
        $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
 
-       # Comtrend 6373
-       $(call Image/Build/CFE,$(1),CT6373-1,6358,CT6373)
        # Comtrend AR-5381u
        $(call Image/Build/CFE,$(1),96328A-1241N,6328,AR-5381u,,--pad 8)
        # Comtrend AR-5387un
@@ -363,6 +361,8 @@ $(eval $(call CfeImageDTB,AR1004G,ar1004g,96348GW-10,6348,AR1004G))
 $(eval $(call CfeImageDTB,CT536_CT5621,ct536plus,96348GW-11,6348,CT536_CT5621))
 # Comtrend CT-5365
 $(eval $(call CfeImageDTB,CT5365,ct-5365,96348A-122,6348,CT-5365))
+# Comtrend CT-6373
+$(eval $(call CfeImageDTB,CT6373,ct-6373,CT6373-1,6358,CT-6373))
 # D-Link DSL-2740B/DSL-2741B, rev C2
 $(eval $(call CfeImageDTB,DSL274XB_C,dsl-274xb-c,96358GW,6358,DSL274XB-C2))
 # D-Link DSL-2740B/DSL-2741B, rev C3
index 5d4c6208fb51982066c19a45004f5b8caa6b1fee..af1ded38fdc6fa5f5fa01efeabe41b01327474d6 100644 (file)
@@ -13,7 +13,7 @@
  /*
   * known 3368 boards
   */
-@@ -2050,6 +2056,124 @@ static struct board_info __initdata boar
+@@ -2050,6 +2056,125 @@ static struct board_info __initdata boar
        .num_spis = ARRAY_SIZE(nb4_spi_devices),
  };
  
@@ -58,6 +58,7 @@
 +
 +static struct board_info __initdata board_ct6373_1 = {
 +      .name                           = "CT6373-1",
++      .of_board_id            = "comtrend,ct-6373",
 +      .expected_cpu_id        = 0x6358,
 +
 +      .has_uart0                      = 1,
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -2391,6 +2515,7 @@ static const struct board_info __initcon
+@@ -2391,6 +2516,7 @@ static const struct board_info __initcon
        &board_dsl_274xb_rev_c,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
index 0f00c4ef08a14dd5a9d491e4c588e7b41f1994e8..bac62473b69d8a0877e31e70b90fa8dd5ff92522 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2316,6 +2316,74 @@ static struct board_info __initdata boar
+@@ -2317,6 +2317,74 @@ static struct board_info __initdata boar
                },
        }
  };
@@ -75,7 +75,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -2518,6 +2586,7 @@ static const struct board_info __initcon
+@@ -2519,6 +2587,7 @@ static const struct board_info __initcon
        &board_ct6373_1,
        &board_HW553,
        &board_spw303v,
index 2171a698734e1dfa09ad05f8882aa47d12eda9ac..2c7193c7dfcfbe539a90455673c4e775d691f9ca 100644 (file)
@@ -17,7 +17,7 @@
  
  #define CT6373_PID_OFFSET             0xff80
  #define CT6373_74X164_GPIO_BASE       64
-@@ -2386,6 +2389,105 @@ static struct board_info __initdata boar
+@@ -2387,6 +2390,105 @@ static struct board_info __initdata boar
  };
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
   * known 6368 boards
   */
-@@ -2589,6 +2691,10 @@ static const struct board_info __initcon
+@@ -2590,6 +2692,10 @@ static const struct board_info __initcon
        &board_DVAG3810BN,
  #endif
  
index 8b368f3fe051a40a1f48237c8eb87d11880f0767..86d507f57bab924d78c51697d5dbfe4a96034d04 100644 (file)
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_rta1025w_16 = {
        .name                           = "RTA1025W_16",
        .of_board_id                    = "dynalink,rta1025w",
-@@ -2662,6 +2713,7 @@ static const struct board_info __initcon
+@@ -2663,6 +2714,7 @@ static const struct board_info __initcon
        &board_96348gw_10,
        &board_96348gw_11,
        &board_FAST2404,
index f3e0bad40584820426272933d704f1c76ff50c93..45ceec345dff455f1fb69c330cabc96dede4e7a2 100644 (file)
  static struct board_info __initdata board_dsl_274xb_f1 = {
        .name                           = "AW4339U",
        .expected_cpu_id                = 0x6328,
-@@ -2694,6 +2821,7 @@ static const struct board_info __initcon
+@@ -2695,6 +2822,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index dd3d8880e3c4d7a83597c1537ea839c18cd94fa5..378ead3d7343ee4b9b62cca309693b7e066ddfef 100644 (file)
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
        .expected_cpu_id                = 0x6328,
-@@ -2820,6 +2929,7 @@ static const struct board_info __initcon
+@@ -2821,6 +2930,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 996d6eaed99405cf66a76acfff8497744cb7cda9..118af0e4d5aab9d3990190dc05dc9e61e888273a 100644 (file)
@@ -92,7 +92,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -2929,6 +3014,7 @@ static const struct board_info __initcon
+@@ -2930,6 +3015,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index fd464745285479eb90bc9ad134ee8ff8d0f874bb..64ca2cd94b44aa377481d9eec2860e532ecb6cc8 100644 (file)
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3028,6 +3077,7 @@ static const struct board_info __initcon
+@@ -3029,6 +3078,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index 5fb3bade979547fb04a0765ab485109198854e0d..29f3d7c5aad7fc22b6315b6f45d12f0335ca48da 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -2675,6 +2676,405 @@ static struct board_info __initdata boar
+@@ -2676,6 +2677,405 @@ static struct board_info __initdata boar
        },
  };
  
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3113,6 +3513,9 @@ static const struct board_info __initcon
+@@ -3114,6 +3514,9 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
index 58c5961ed8e1d50cc74ec2d437e7d6ed33b8e7a1..b22334a5b49cecee86ff5ce076c02420d1e21d77 100644 (file)
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3478,6 +3532,7 @@ static const struct board_info __initcon
+@@ -3479,6 +3533,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index ff76fbda926375008fc41b88a5123fbefd4326c1..6ff06481504a639367af5f9229247f52390ec0e8 100644 (file)
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3522,6 +3638,7 @@ static const struct board_info __initcon
+@@ -3523,6 +3639,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index 387602097f52cb947552d220f409c5b7d80f69d8..cc8ca322583ed03eb33db1ad984f03a7ae5311cd 100644 (file)
@@ -6,7 +6,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3477,6 +3477,96 @@ static struct board_info __initdata boar
+@@ -3478,6 +3478,96 @@ static struct board_info __initdata boar
        .devs = nb6_devices,
        .num_devs = ARRAY_SIZE(nb6_devices),
  };
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -3694,6 +3784,7 @@ static const struct board_info __initcon
+@@ -3695,6 +3785,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index 2ae479aca32fec3edd0bc2734275157b014a2b95..a4de6a286b9785345039b53f985ba4374a05d06f 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3952,6 +4039,9 @@ static const struct board_info __initcon
+@@ -3953,6 +4040,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index 1de5d8fb5f2672c1963bddfdefd11d5039f5bbc2..dbe0ebaa3c0265c377abf0a2b0da25c78ba88678 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4041,6 +4129,7 @@ static const struct board_info __initcon
+@@ -4042,6 +4130,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index caadafdfcb0285e517a3fffebd236963e261b6a3..093cdcbb072820e966044b81abaab98422022be4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4121,6 +4121,75 @@ static struct board_info __initdata boar
+@@ -4122,6 +4122,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4201,6 +4270,9 @@ static const struct board_info __initcon
+@@ -4202,6 +4271,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index 6335c296f8c261b90f912da9a3fbc7e4f4f8129e..7438e1617f73382f68a58ece2511aa66946edbb1 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4241,6 +4287,7 @@ static const struct board_info __initcon
+@@ -4242,6 +4288,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index 505aa3802046fa0af2bad01736e8f8b18cbe8edd..6ddfd22621de720fb28a49b26ad1fe7e000b467d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4233,6 +4233,108 @@ static struct board_info __initdata boar
+@@ -4234,6 +4234,108 @@ static struct board_info __initdata boar
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4319,6 +4421,7 @@ static const struct board_info __initcon
+@@ -4320,6 +4422,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index 00a472b7f60256bd75ff0210aa1305d94c5f41c9..97d5a343b7233a3a2ed3e4026a9075285cbcfef3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4170,6 +4170,131 @@ static struct board_info __initdata boar
+@@ -4171,6 +4171,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4420,6 +4545,7 @@ static const struct board_info __initcon
+@@ -4421,6 +4546,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 8401204dd55431430243af1d07ee408bfa48c124..89d93aead57de64584cd53111b0ce1315000bd73 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4164,6 +4165,117 @@ static struct board_info __initdata boar
+@@ -4165,6 +4166,117 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4543,6 +4655,7 @@ static const struct board_info __initcon
+@@ -4544,6 +4656,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index e88c1e142addb778b7f4a40df18553a24b58399d..38c6e073b46a9257e06ae1325da8d2aaf97c4a81 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4166,6 +4166,116 @@ static struct board_info __initdata boar
+@@ -4167,6 +4167,116 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4655,6 +4765,7 @@ static const struct board_info __initcon
+@@ -4656,6 +4766,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index e860bcc48d7a52919003a2893b19270de6f81416..f23ba8594d2a50461ecf3848053722fb80abaf39 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4276,6 +4276,116 @@ static struct board_info __initdata boar
+@@ -4277,6 +4277,116 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4766,6 +4876,7 @@ static const struct board_info __initcon
+@@ -4767,6 +4877,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 61300806349be7cf0b008013a46b29c563e48cf0..cb4a17406bde45f0776e975b65310afbd4e6bf85 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4175,6 +4175,96 @@ static struct sprom_fixup __initdata vr3
+@@ -4176,6 +4176,96 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .expected_cpu_id                = 0x6368,
-@@ -4875,6 +4965,7 @@ static const struct board_info __initcon
+@@ -4876,6 +4966,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index f135b4c78e16003ec98c24064a32e23e5d9cd31a..e8409818f6f6abf6cd21ff2cf2c8e858027a5fc0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3222,6 +3222,56 @@ static struct board_info __initdata boar
+@@ -3223,6 +3223,56 @@ static struct board_info __initdata boar
        .num_spis = ARRAY_SIZE(ct6373_spi_devices),
  };
  
@@ -57,7 +57,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -4949,6 +4999,7 @@ static const struct board_info __initcon
+@@ -4950,6 +5000,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 3b5c8ad073b4efc88f4f48c61903bf58dd0264b9..0d2fabcb19e42f400846cef47e8afe277bb30484 100644 (file)
@@ -96,7 +96,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -4950,6 +5039,7 @@ static const struct board_info __initcon
+@@ -4951,6 +5040,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index ee4b313fa2b0343ccea1f40fb02a2edd390d746b..6cdd3bec0c93f9661e262b2bc9dcab4eb6af904b 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5033,6 +5168,7 @@ static const struct board_info __initcon
+@@ -5034,6 +5169,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 8b0bbc17906bb61e605afb1d850446ace7ba718c..4a1f133c8a94a4750ab98ea25e59912536cd30e2 100644 (file)
@@ -22,3 +22,13 @@ define Profile/CT5365/Description
   Package set optimized for CT-5365.
 endef
 $(eval $(call Profile,CT5365))
+
+define Profile/CT6373
+  NAME:=Comtrend CT-6373
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/CT6373/Description
+  Package set optimized for CT-6373.
+endef
+$(eval $(call Profile,CT6373))