ramips: use full 8MB flash on ZyXEL Keenetic
authorAlexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>
Wed, 8 Apr 2020 18:43:36 +0000 (21:43 +0300)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 12 Apr 2020 11:46:04 +0000 (13:46 +0200)
ZyXEL Keenetic has 8MB flash, but OpenWrt uses only 4MB.
This commit fixes the problem.

WikiDevi page [1] says that ZyXEL Keenetic has FLA1: 8 MiB, there is
an article with specs [2] (in Russian).

[1] https://wikidevi.wi-cat.ru/ZyXEL_Keenetic
[2] https://3dnews.ru/608774/page-2.html

Fixes: FS#2487
Fixes: a7cbf59e0e04 ("ramips: add new device ZyXEL Keenetic as kn")
Signed-off-by: Alexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>
(cherry picked from commit fea232ae8feb6af780fd4fa78ebe9231778bf75a)

target/linux/ramips/dts/kn.dts
target/linux/ramips/image/rt305x.mk

index 1f9928e59af039e6a3e01df87014e7a91f33db3d..baa24a961f5e31c39cd3883cb38fd7dfb21a4225 100644 (file)
@@ -48,7 +48,7 @@
                        partition@50000 {
                                compatible = "denx,uimage";
                                label = "firmware";
-                               reg = <0x50000 0x3b0000>;
+                               reg = <0x50000 0x7b0000>;
                        };
                };
        };
index f59a74894932fd31d4f7bb283c69160f1e4ab6b0..739656cc4038df6c2900be2390e8bf40dbf0a248 100644 (file)
@@ -905,7 +905,7 @@ TARGET_DEVICES += xdxrn502j
 define Device/kn
   DTS := kn
   BLOCKSIZE := 64k
-  IMAGE_SIZE := $(ralink_default_fw_size_4M)
+  IMAGE_SIZE := 7872k
   DEVICE_TITLE := ZyXEL Keenetic
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
   DEFAULT := n