ubox: fix init script validation of log_ip option
authorJo-Philipp Wich <jo@mein.io>
Fri, 28 May 2021 13:23:14 +0000 (15:23 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 28 May 2021 13:26:31 +0000 (15:26 +0200)
The underlying logread process uses usock() to handle remote connections
which is able to handle both hostnames and IP addresses.

Ref: https://github.com/openwrt/luci/issues/5077
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(backported from commit ec83fb9ced138b7945135adffb9ff0ba63b695ec)

package/system/ubox/Makefile
package/system/ubox/files/log.init

index 6e67951929f4e47dbf88dd72f0dda161349a1ba1..d303603c0d631cde2d212ae6b36ef107b18d0c9c 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ubox
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/ubox.git
index ba9c124c8ba6e71b875685680fde4f268f52659e..bfaf31ca9fd9b3c1bf53d531a55cbf812d6ce6a3 100644 (file)
@@ -15,7 +15,7 @@ validate_log_section()
                'log_file:string' \
                'log_size:uinteger' \
                'log_hostname:string' \
-               'log_ip:ipaddr' \
+               'log_ip:host' \
                'log_remote:bool:1' \
                'log_port:port:514' \
                'log_proto:or("tcp", "udp"):udp' \