renamed wrt54g3gv2-vf images
authorMarkus Wigge <mwigge@marcant.net>
Thu, 1 Jul 2010 10:48:13 +0000 (10:48 +0000)
committerMarkus Wigge <mwigge@marcant.net>
Thu, 1 Jul 2010 10:48:13 +0000 (10:48 +0000)
'factory' and 'sysupgrade' did not make much sense. A discussion
with jow convinced me that .trx results in a helpdesk disaster.
So I decided to use '.bin' for normal bin-headers and '.noheader.bin'
for the trx-v2 image.
I fixed the wiki accordingly.

SVN-Revision: 22013

target/linux/brcm47xx/image/Makefile

index b839a42d232754be3254ef8314c1eaafc11189e9..69a31e7554fe519449acc9a48e07835c4ad95257 100644 (file)
@@ -35,7 +35,7 @@ define Image/Build/CyberTAN
        $(STAGING_DIR_HOST)/bin/addpattern -4 -p $(3) -v v$(4) -i $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx -o $(BIN_DIR)/openwrt-$(2)-$(5).bin $(if $(6),-s $(6))
 endef
 define Image/Build/CyberTAN2
-       $(STAGING_DIR_HOST)/bin/addpattern -4 -p $(3) -v v$(4) -i $(BIN_DIR)/openwrt-$(2)-$(5)-sysupgrade.bin -o $(BIN_DIR)/openwrt-$(2)-$(5)-factory.bin $(if $(6),-s $(6))
+       $(STAGING_DIR_HOST)/bin/addpattern -4 -p $(3) -v v$(4) -i $(BIN_DIR)/openwrt-$(2)-$(5).noheader.bin -o $(BIN_DIR)/openwrt-$(2)-$(5).bin $(if $(6),-s $(6))
 endef
 define Image/Build/CyberTANHead
        $(STAGING_DIR_HOST)/bin/addpattern -5 -p $(3) -v v$(4) -i /dev/null -o $(KDIR)/openwrt-$(2)-header.bin $(if $(6),-s $(6))
@@ -61,7 +61,7 @@ endef
 
 define Image/Build/trxV2
        $(call Image/Build/CyberTANHead,$(1),$(2),$(3),$(4),$(5),$(if $(6),$(6)))
-       $(STAGING_DIR_HOST)/bin/trx -2 -o $(BIN_DIR)/openwrt-$(2)-$(5)-sysupgrade.bin \
+       $(STAGING_DIR_HOST)/bin/trx -2 -o $(BIN_DIR)/openwrt-$(2)-$(5).noheader.bin \
                -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma \
                $(call trxalign/$(1),$(1),$(KDIR)/openwrt-$(2)-header.bin)
        $(call Image/Build/CyberTAN2,$(1),$(2),$(3),$(4),$(5),$(if $(6),$(6)))