kernel: add a kmod package for the SoC S/PDIF codec
authorAndre Heider <a.heider@gmail.com>
Tue, 8 Oct 2019 19:15:44 +0000 (21:15 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 11 Oct 2020 15:45:02 +0000 (17:45 +0200)
Size of the modules for a Cortex A7 build:
43920 linux-5.4.66/sound/soc/codecs/snd-soc-spdif-rx.ko
44044 linux-5.4.66/sound/soc/codecs/snd-soc-spdif-tx.ko

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/kernel/linux/modules/sound.mk

index faee6043dcb839e09a04735673a0a25ff83546fe..692ede30ee232763fb70f3058addc9958176dbd4 100644 (file)
@@ -254,6 +254,20 @@ endef
 $(eval $(call KernelPackage,sound-soc-imx-sgtl5000))
 
 
+define KernelPackage/sound-soc-spdif
+  TITLE:=SoC S/PDIF codec support
+  KCONFIG:=CONFIG_SND_SOC_SPDIF
+  FILES:= \
+       $(LINUX_DIR)/sound/soc/codecs/snd-soc-spdif-tx.ko \
+       $(LINUX_DIR)/sound/soc/codecs/snd-soc-spdif-rx.ko
+  DEPENDS:=+kmod-sound-soc-core
+  AUTOLOAD:=$(call AutoProbe,snd-soc-spdif-tx snd-soc-spdif-rx)
+  $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-spdif))
+
+
 define KernelPackage/pcspkr
   DEPENDS:=@TARGET_x86 +kmod-input-core
   TITLE:=PC speaker support