ipq40xx: add e2600ac c2 to dsa
author张 鹏 <sd20@qxwlan.com>
Wed, 22 Feb 2023 12:55:44 +0000 (20:55 +0800)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 29 May 2023 10:23:47 +0000 (12:23 +0200)
Convert E2600ac c2 to DSA and enable it.

Signed-off-by: 张 鹏 <sd20@qxwlan.com>
[ rename port to more generic name ]
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-e2600ac-c2.dts
target/linux/ipq40xx/image/generic.mk

index 0d9be90ddb0d0ff3e27d03e04cb7f32aed0c5532..d6b19c981eab991f7b5e26a288273002e28a6506 100644 (file)
@@ -100,6 +100,9 @@ ipq40xx_setup_interfaces()
        qxwlan,e2600ac-c1)
                ucidef_set_interfaces_lan_wan "sw-eth1" "sw-eth2"
                ;;
+       qxwlan,e2600ac-c2)
+               ucidef_set_interfaces_lan_wan "sw-eth1 sw-eth2" "sw-eth3"
+               ;;
        zte,mf286d)
                ucidef_set_interfaces_lan_wan "lan2 lan3 lan4" "wan"
                ;;
index 1f88322a4f1e8c84949964569d4453a7bf84bcec..2ad794e8ecb3a2dc6ecf5b01edfb721af7b7cedb 100644 (file)
                                precal_art_5000: precal@5000 {
                                        reg = <0x5000 0x2f20>;
                                };
+
+                               macaddr_gmac0: macaddr@0 {
+                                       reg = <0x0 0x6>;
+                               };
+
+                               macaddr_gmac1: macaddr@6 {
+                                       reg = <0x6 0x6>;
+                               };
                        };
                };
        };
        nvmem-cells = <&precal_art_5000>;
        qcom,ath10k-calibration-variant = "Qxwlan-E2600AC-C2";
 };
+
+&gmac {
+       status = "okay";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport2 {
+       status = "okay";
+       label = "sw-eth1";
+
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_gmac0>;
+};
+
+&swport4 {
+       status = "okay";
+       label = "sw-eth2";
+
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_gmac0>;
+};
+
+&swport5 {
+       status = "okay";
+
+       label = "sw-eth3";
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_gmac1>;
+};
index 6cde091b2b51dfeaaa784fa41261eef6df0fec63..59dfb0062839a000e170d31dd2504b5265787991 100644 (file)
@@ -1046,8 +1046,7 @@ define Device/qxwlan_e2600ac-c2
        BLOCKSIZE := 128k
        PAGESIZE := 2048
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += qxwlan_e2600ac-c2
+TARGET_DEVICES += qxwlan_e2600ac-c2
 
 define Device/sony_ncp-hg100-cellular
        $(call Device/FitImage)