kernel: bump 4.9 to 4.9.128
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 20 Sep 2018 12:35:27 +0000 (14:35 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 21 Sep 2018 11:23:59 +0000 (13:23 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm47xx/patches-4.9/159-cpu_fixes.patch

index 4c35b124a46c8d3b72c935cb80e0b19597f94779..c6124d2809a503e31c78ad02bd9ee9d255c0faf2 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .127
 LINUX_VERSION-4.14 = .70
+LINUX_VERSION-4.9 = .128
 
-LINUX_KERNEL_HASH-4.9.127 = 9477aeaded97589a40d7cbbfeebfa7a8f863130c0729a8dc5cdbcf48eb6fdd0f
 LINUX_KERNEL_HASH-4.14.70 = c5dfd832477f8856b5b094ab62cc8c8491d04b76b2ec5ebb0126e554891ee32c
+LINUX_KERNEL_HASH-4.9.128 = bdb76f48491a6aadc89c0f0f7fdc240d77cee54da5aac59da0b5d98e226b6f12
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 9725779c3ecce23860f45e0bd13148e28dda975a..b424da8d32b1eeae33a96b4715d627329f65622c 100644 (file)
        if (dc_lsize == 0)
                r4k_blast_dcache = (void *)cache_noop;
        else if (dc_lsize == 16)
-@@ -955,6 +967,8 @@ static void local_r4k_flush_cache_sigtra
+@@ -957,6 +969,8 @@ static void local_r4k_flush_cache_sigtra
        }
  
        R4600_HIT_CACHEOP_WAR_IMPL;
        if (!cpu_has_ic_fills_f_dc) {
                if (dc_lsize)
                        vaddr ? flush_dcache_line(addr & ~(dc_lsize - 1))
-@@ -1843,6 +1857,17 @@ static void coherency_setup(void)
+@@ -1845,6 +1859,17 @@ static void coherency_setup(void)
         * silly idea of putting something else there ...
         */
        switch (current_cpu_type()) {
        case CPU_R4000PC:
        case CPU_R4000SC:
        case CPU_R4000MC:
-@@ -1889,6 +1914,15 @@ void r4k_cache_init(void)
+@@ -1891,6 +1916,15 @@ void r4k_cache_init(void)
        extern void build_copy_page(void);
        struct cpuinfo_mips *c = &current_cpu_data;
  
        probe_pcache();
        probe_vcache();
        setup_scache();
-@@ -1966,7 +2000,15 @@ void r4k_cache_init(void)
+@@ -1968,7 +2002,15 @@ void r4k_cache_init(void)
         */
        local_r4k___flush_cache_all(NULL);