ath79: fix SUPPORTED_DEVICES for WNDR4300 and WNDR3700v4
authorMichal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
Mon, 20 Jan 2020 20:34:02 +0000 (21:34 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 20 Jan 2020 23:29:25 +0000 (00:29 +0100)
Kernel partition increase to 4 MiBs for Netgear WNDR3700v4 and WNDR4300
routers breaks sysupgrade image compatibility with ar71xx builds.
Therefore, SUPPORTED_DEVICES variable has to be removed for both devices
from target makefile.

Reported-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Signed-off-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
target/linux/ath79/image/nand.mk

index f6929cd88e7e38a12a76d5b5cf4ba8cd2b6c417f..95ddca26b0cb6380ee1d99514cdc67c23f058a60 100644 (file)
@@ -138,7 +138,6 @@ define Device/netgear_wndr3700-v4
   NETGEAR_KERNEL_MAGIC := 0x33373033
   NETGEAR_BOARD_ID := WNDR3700v4
   NETGEAR_HW_ID := 29763948+128+128
-  SUPPORTED_DEVICES += wndr3700v4
   $(Device/netgear_ath79_nand)
 endef
 TARGET_DEVICES += netgear_wndr3700-v4
@@ -149,7 +148,6 @@ define Device/netgear_wndr4300
   NETGEAR_KERNEL_MAGIC := 0x33373033
   NETGEAR_BOARD_ID := WNDR4300
   NETGEAR_HW_ID := 29763948+0+128+128+2x2+3x3
-  SUPPORTED_DEVICES += wndr4300
   $(Device/netgear_ath79_nand)
 endef
 TARGET_DEVICES += netgear_wndr4300