kernel: load softdog on boot
authorFelix Fietkau <nbd@openwrt.org>
Fri, 6 Nov 2015 10:53:11 +0000 (10:53 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 6 Nov 2015 10:53:11 +0000 (10:53 +0000)
same as for hardware watchdogs, otherwise
procd cannot initialize it.

Signed-off-by: Ulrich Weber <uw@ocedo.com>
SVN-Revision: 47394

package/kernel/linux/modules/other.mk

index 022410f2be70e0160c5b453045010bf5055b8574..73251b8cf8f3e2fcf9d3d94c183d4b2f5eec195f 100644 (file)
@@ -408,7 +408,7 @@ define KernelPackage/softdog
   TITLE:=Software watchdog driver
   KCONFIG:=CONFIG_SOFT_WATCHDOG
   FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/softdog.ko
-  AUTOLOAD:=$(call AutoLoad,50,softdog)
+  AUTOLOAD:=$(call AutoLoad,50,softdog,1)
 endef
 
 define KernelPackage/softdog/description