iptables: enable nftable support by default
authorPaul Spooren <mail@aparcar.org>
Thu, 13 Jan 2022 07:50:19 +0000 (08:50 +0100)
committerPaul Spooren <mail@aparcar.org>
Thu, 13 Jan 2022 23:42:28 +0000 (00:42 +0100)
OpenWrt plans to move over to firewall4 which uses nftables under the
hood. To allow a smooth migration the package `iptables-nft` offer a
transparent wrapper to apply iptables rules to nftables.

Without the config option for nftables the package isn't installed and
therefore can't be tested. This commit enabled it and therefore provides
the wrapper.

The size of the iptables package increases from 25436 to 26500 Bytes.

Signed-off-by: Paul Spooren <mail@aparcar.org>
package/network/utils/iptables/Makefile

index 42d9af14b07f837647198a59aaecd9eeec9a3260..6aee5c6cafbba5b6334895f3fb7cafd9edcc2554 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
 PKG_VERSION:=1.8.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=https://netfilter.org/projects/iptables/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -60,7 +60,7 @@ define Package/iptables/config
 
   config IPTABLES_NFTABLES
        bool "Enable Nftables support"
-       default n
+       default y
        help
                This enable nftables support in iptables.
 endef