if CONFIG_BUILD_NLS is selected, compile uClibc with locale support
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Jan 2012 15:11:11 +0000 (15:11 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Jan 2012 15:11:11 +0000 (15:11 +0000)
SVN-Revision: 29633

Config.in
toolchain/uClibc/Makefile

index 901d7400646d209104c496addaa07ddd1b9f9644..4e874a69de90a6a7c8b6b5ff01baead5fb2afa6d 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -145,7 +145,7 @@ menu "Global build settings"
                bool "Compile with full language support"
                help
                  When this option is enabled, packages are built with the full versions of iconv and GNU gettext
                bool "Compile with full language support"
                help
                  When this option is enabled, packages are built with the full versions of iconv and GNU gettext
-                 instead of the default OpenWrt stubs.
+                 instead of the default OpenWrt stubs. If uClibc is used, it is also built with locale support.
 
        config SHADOW_PASSWORDS
                bool
 
        config SHADOW_PASSWORDS
                bool
index 5f4ddb5d9f2f600a8f6500b550b5a9574e73b4ed..8c658448b331669cfa68c38d0dc88f198e4bd502 100644 (file)
@@ -78,6 +78,7 @@ define Host/Prepare
                -e 's,^.*UCLIBC_HAS_FPU.*,UCLIBC_HAS_FPU=$(if $(CONFIG_SOFT_FLOAT),n,y),g' \
                -e 's,^.*UCLIBC_HAS_SOFT_FLOAT.*,UCLIBC_HAS_SOFT_FLOAT=$(if $(CONFIG_SOFT_FLOAT),y,n),g' \
                -e 's,^.*UCLIBC_HAS_SHADOW.*,UCLIBC_HAS_SHADOW=$(if $(CONFIG_SHADOW_PASSWORDS),y,n),g' \
                -e 's,^.*UCLIBC_HAS_FPU.*,UCLIBC_HAS_FPU=$(if $(CONFIG_SOFT_FLOAT),n,y),g' \
                -e 's,^.*UCLIBC_HAS_SOFT_FLOAT.*,UCLIBC_HAS_SOFT_FLOAT=$(if $(CONFIG_SOFT_FLOAT),y,n),g' \
                -e 's,^.*UCLIBC_HAS_SHADOW.*,UCLIBC_HAS_SHADOW=$(if $(CONFIG_SHADOW_PASSWORDS),y,n),g' \
+               -e 's,^.*UCLIBC_HAS_LOCALE.*,UCLIBC_HAS_LOCALE=$(if $(CONFIG_BUILD_NLS),y,n),g' \
                $(HOST_BUILD_DIR)/.config
        $(MAKE) -C $(HOST_BUILD_DIR) oldconfig KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS"
        $(MAKE) -C $(HOST_BUILD_DIR)/extra/config conf KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS"
                $(HOST_BUILD_DIR)/.config
        $(MAKE) -C $(HOST_BUILD_DIR) oldconfig KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS"
        $(MAKE) -C $(HOST_BUILD_DIR)/extra/config conf KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS"