x86: Add kmod-dwmac-intel
[openwrt/staging/hauke.git] / tools / sstrip / Makefile
index 681e533be436bd2b7b8f8fa93603830b6ffee0b3..55a7fa744667dc977090c3623aaf02ef4cfab7b9 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,15 +7,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sstrip
+PKG_VERSION:=3.2
 
-include $(INCLUDE_DIR)/host-build.mk
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/ELFkickers-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://www.muppetlabs.com/~breadbox/pub/software
+PKG_SOURCE:=ELFkickers-$(PKG_VERSION).tar.gz
+PKG_HASH:=9b81e6c53e0c94fc198d9882eb737156f36d565152dc32118897c77b06a2687c
 
-define Host/Compile
-       $(HOSTCC) $(HOST_CFLAGS) -I./include -include endian.h -o $(HOST_BUILD_DIR)/sstrip src/sstrip.c
-endef
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Install
-       $(CP) $(HOST_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
+       $(CP) $(HOST_BUILD_DIR)/bin/sstrip $(STAGING_DIR_HOST)/bin/
 endef
 
 define Host/Clean