tools/patchelf: update to 0.18.0
[openwrt/staging/dedeckeh.git] / tools / mpc / Makefile
index f0918b3b1d8c13891de8fe7a9950ee6f9430f5a7..97e94291cb7c23a789835910636d65ab925e7234 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpc
-PKG_VERSION:=0.9
+PKG_VERSION:=1.3.1
 
-PKG_SOURCE_URL:=http://www.multiprecision.org/mpc/download/
+PKG_SOURCE_URL:=@GNU/mpc/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=0d6acab8d214bd7d1fbbc593e83dd00d
+PKG_HASH:=ab642492f5cf882b74aa0cb730cd410a81edcdbec895183ce930e706c1c759b8
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -20,16 +22,11 @@ unexport CFLAGS
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
-       --with-mpfr=$(TOPDIR)/staging_dir/host \
-       --with-gmp=$(TOPDIR)/staging_dir/host
-
-define Host/Configure
-       (cd $(HOST_BUILD_DIR)/$(3); \
-               $(HOST_CONFIGURE_CMD) \
-               $(HOST_CONFIGURE_VARS) \
-               $(HOST_CONFIGURE_ARGS); \
-       )
-endef
+       --with-mpfr=$(STAGING_DIR_HOST) \
+       --with-gmp=$(STAGING_DIR_HOST)
 
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
 
 $(eval $(call HostBuild))