tools/libressl: update to version 3.7.3
[openwrt/staging/nbd.git] / tools / libressl / Makefile
index a068a7c8346fa8c06bce22a79493d25dbc7ba571..4072194763f125105bfd913857dcca729061c651 100644 (file)
@@ -8,20 +8,33 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libressl
-PKG_VERSION:=2.6.4
-PKG_HASH:=638a20c2f9e99ee283a841cd787ab4d846d1880e180c4e96904fc327d419d11f
-PKG_RELEASE:=1
+PKG_VERSION:=3.7.3
+PKG_HASH:=7948c856a90c825bd7268b6f85674a8dcd254bae42e221781b24e3f8dc335db3
+
+PKG_CPE_ID:=cpe:/a:openbsd:libressl
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://mirror.ox.ac.uk/pub/OpenBSD/LibreSSL \
+PKG_SOURCE_URL:=https://mirror.ox.ac.uk/pub/OpenBSD/LibreSSL \
        http://ftp.jaist.ac.jp/pub/OpenBSD/LibreSSL \
-       http://ftp.openbsd.org/pub/OpenBSD/LibreSSL
+       https://ftp.openbsd.org/pub/OpenBSD/LibreSSL
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_CONFIGURE_ARGS += --disable-shared
-HOST_CFLAGS += $(FPIC)
+HOSTCC := $(HOSTCC_NOCACHE)
+
+HOST_CFLAGS += $(HOST_FPIC)
+
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --disable-asm \
+       --with-pic \
+       --disable-tests
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
 
 $(eval $(call HostBuild))