tools/libressl: update to version 3.7.3
[openwrt/staging/nbd.git] / tools / libressl / Makefile
index 236a7c2c307510b9589fdee896c798530ec5de3f..4072194763f125105bfd913857dcca729061c651 100644 (file)
@@ -8,14 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libressl
-PKG_VERSION:=3.5.3
-PKG_HASH:=3ab5e5eaef69ce20c6b170ee64d785b42235f48f2e62b095fca5d7b6672b8b28
-PKG_RELEASE:=1
+PKG_VERSION:=3.7.3
+PKG_HASH:=7948c856a90c825bd7268b6f85674a8dcd254bae42e221781b24e3f8dc335db3
 
 PKG_CPE_ID:=cpe:/a:openbsd:libressl
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://mirror.ox.ac.uk/pub/OpenBSD/LibreSSL \
+PKG_SOURCE_URL:=https://mirror.ox.ac.uk/pub/OpenBSD/LibreSSL \
        http://ftp.jaist.ac.jp/pub/OpenBSD/LibreSSL \
        https://ftp.openbsd.org/pub/OpenBSD/LibreSSL
 
@@ -24,11 +23,18 @@ HOST_BUILD_PARALLEL:=1
 include $(INCLUDE_DIR)/host-build.mk
 
 HOSTCC := $(HOSTCC_NOCACHE)
-HOST_CONFIGURE_ARGS += --enable-static --disable-shared --disable-tests
+
 HOST_CFLAGS += $(HOST_FPIC)
 
-ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
-HOST_CONFIGURE_ARGS += --disable-asm
-endif
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --disable-asm \
+       --with-pic \
+       --disable-tests
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
 
 $(eval $(call HostBuild))