tools: assign PKG_CPE_ID
[openwrt/staging/nbd.git] / tools / gmp / Makefile
index ca80415bc863e5a8f76d3c7577ab6418ac59e5c4..c48069dd7bc616273ddad03edd2b78116ead4725 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2013 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=5.1.2
+PKG_VERSION:=6.2.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_MD5SUM:=06fe2ca164221c59ce74867155cfc1ac
+PKG_HASH:=fd4829912cddd12f84181c3451cc752be224643e87fac497b69edddadc49b4f2
+PKG_CPE_ID:=cpe:/a:gmplib:gmp
 
 HOST_FIXUP:=autoreconf
 
@@ -24,7 +25,15 @@ unexport CFLAGS
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
-       --enable-cxx \
-       --enable-mpbsd
+       --disable-assembly \
+       --enable-cxx
+
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
 
 $(eval $(call HostBuild))