tools/patchelf: update to 0.18.0
[openwrt/staging/dedeckeh.git] / tools / gmp / Makefile
index 514187ce6e376593810c4707137c2b8274cc66fb..cfd6e30e04ab036d56b5b4704fc6477d21ab8b2d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 -2010 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=4.3.2
+PKG_VERSION:=6.2.1
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=dd60683d7057917e34630b4a787932e8
+PKG_HASH:=fd4829912cddd12f84181c3451cc752be224643e87fac497b69edddadc49b4f2
+
+HOST_FIXUP:=autoreconf
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -20,16 +24,15 @@ unexport CFLAGS
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
-       --enable-cxx \
-       --enable-mpbsd
-
-define Host/Configure
-       (cd $(HOST_BUILD_DIR)/$(3); \
-               $(HOST_CONFIGURE_CMD) \
-               $(HOST_CONFIGURE_VARS) \
-               $(HOST_CONFIGURE_ARGS); \
-       )
-endef
+       --disable-assembly \
+       --enable-cxx
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
 
 $(eval $(call HostBuild))