tools/gengetopt: override SUBDIRS variable with Makefile
[openwrt/staging/stintel.git] / tools / gengetopt / Makefile
index 6d2b85e658268a2e51b65640c31711666a1780d6..5a5b5eb7cbb7a7326db1b7cc19dc4f0da0ca92ed 100644 (file)
@@ -1,24 +1,28 @@
 #
 # Copyright (C) 2014 OpenWrt.org
 #
-# This is free software, licengengetopt under the GNU General Public License v2.
+# This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gengetopt
-PKG_VERSION:=2.22.6
+PKG_VERSION:=2.23
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_HASH:=30b05a88604d71ef2a42a2ef26cd26df242b41f5b011ad03083143a31d9b01f7
+PKG_HASH:=b941aec9011864978dd7fdeb052b1943535824169d2aa2b0e7eae9ab807584ac
 
-HOST_FIXUP := autoreconf
+PKG_SUBDIRS:=$$$$(foreach dir,gl src skels,$$$$(wildcard $$$$(dir)) )
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Host/Compile
+       $(call Host/Compile/Default,SUBDIRS='$(PKG_SUBDIRS)')
+endef
+
 define Host/Install
        $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/gengetopt $(STAGING_DIR_HOST)/bin/
 endef