hostapd: add support for authenticating with multiple PSKs via ubus helper
[openwrt/staging/nbd.git] / tools / flex / Makefile
index 760721a16fcc02f92c1c35592239d4a9652b5759..177136b78c77c31c56db2fc993d1273d3dd81562 100644 (file)
@@ -7,20 +7,35 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
+PKG_CPE_ID:=cpe:/a:westes:flex
 PKG_VERSION:=2.6.4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/westes/flex/releases/download/v$(PKG_VERSION)/
 PKG_HASH:=e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995
 
+HOST_FIXUP:=autoreconf
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
 
+define Host/Compile
+       $(call Host/Compile/Default,SUBDIRS='src tools')
+endef
+
+define Host/Install
+       $(call Host/Compile/Default,install SUBDIRS='src tools')
+       $(LN) flex $(STAGING_DIR_HOST)/bin/lex
+endef
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall SUBDIRS='src tools')
+endef
+
 define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       rm -f $(STAGING_DIR_HOST)/bin/lex
        $(call Host/Clean/Default)
 endef